aboutsummaryrefslogtreecommitdiff
path: root/plugins/ProfileEditor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/ProfileEditor/CMakeLists.txt')
-rw-r--r--plugins/ProfileEditor/CMakeLists.txt11
1 files changed, 8 insertions, 3 deletions
diff --git a/plugins/ProfileEditor/CMakeLists.txt b/plugins/ProfileEditor/CMakeLists.txt
index e5654ff..7ded842 100644
--- a/plugins/ProfileEditor/CMakeLists.txt
+++ b/plugins/ProfileEditor/CMakeLists.txt
@@ -21,7 +21,12 @@ target_include_directories(ProfileEditorPlugin
PRIVATE ../../lib/web)
target_link_libraries(ProfileEditorPlugin
- PRIVATE Qt5::Widgets
- PRIVATE Qt5::WebEngineWidgets)
+ PRIVATE Qt5::Widgets
+ PRIVATE Qt5::WebEngineWidgets
+)
-install(TARGETS ProfileEditorPlugin LIBRARY DESTINATION lib/smolbote CONFIGURATIONS Release)
+if(WIN32)
+ install(TARGETS ProfileEditorPlugin RUNTIME DESTINATION lib/smolbote CONFIGURATIONS Release)
+else()
+ install(TARGETS ProfileEditorPlugin LIBRARY DESTINATION lib/smolbote CONFIGURATIONS Release)
+endif()