aboutsummaryrefslogtreecommitdiff
path: root/plugins/ProfileEditor/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/ProfileEditor/meson.build')
-rw-r--r--plugins/ProfileEditor/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/plugins/ProfileEditor/meson.build b/plugins/ProfileEditor/meson.build
index c44f5c4..caa3a75 100644
--- a/plugins/ProfileEditor/meson.build
+++ b/plugins/ProfileEditor/meson.build
@@ -11,3 +11,14 @@ ProfileEditorPlugin_lib = shared_library('ProfileEditorPlugin',
include_directories: include,
install: true, install_dir: join_paths(get_option('libdir'), 'smolbote/plugins')
)
+
+test('run', executable('ProfileEditor', 'test/main.cpp',
+ link_with: ProfileEditorPlugin,
+ include_directories: plugininterfaces_include,
+ dependencies: [ dep_qt5 ]),
+ args: [ '-platform', 'offscreen' ],
+ env: 'autoclose=1',
+ suite: 'ProfileEdtitorPlugin'
+)
+
+test('load', poi_plugin_loader, suite: 'ProfileEditorPlugin', args: ProfileEditorPlugin.full_path())