aboutsummaryrefslogtreecommitdiff
path: root/plugins/smolblok_hostlist/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/smolblok_hostlist/meson.build')
-rw-r--r--plugins/smolblok_hostlist/meson.build9
1 files changed, 5 insertions, 4 deletions
diff --git a/plugins/smolblok_hostlist/meson.build b/plugins/smolblok_hostlist/meson.build
index a3e64a7..7dde699 100644
--- a/plugins/smolblok_hostlist/meson.build
+++ b/plugins/smolblok_hostlist/meson.build
@@ -20,16 +20,17 @@ plugin = shared_library('smolblokHostlistPlugin',
)
# tests
-test('rule parsing', executable('rule',
- sources: 'test/rule.cpp',
- dependencies: [dep_qt5, dep_catch, dep_hostlistfilter]))
+test('rule', executable('rule', sources: 'test/rule.cpp', dependencies: [dep_qt5, dep_catch, dep_hostlistfilter]), suite: 'hostlist')
test('filterlist', executable('filterlist',
sources: 'test/filterlist.cpp',
dependencies: [dep_qt5, dep_catch, dep_hostlistfilter]),
- env: 'HOSTLIST_TXT='+meson.current_source_dir()/'test/hostlist.txt'
+ env: 'HOSTLIST_TXT='+meson.current_source_dir()/'test/hostlist.txt',
+ suite: 'hostlist'
)
+test('plugin', smolblok_load, workdir: meson.build_root(), args: plugin.full_path(), suite: 'hostlist')
+
# fuzzer
if meson.get_compiler('cpp').has_multi_arguments('-g', '-fsanitize=fuzzer')
executable('hostlist-fuzzer',