aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt13
1 files changed, 10 insertions, 3 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index c3b96e2..6f231b4 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -21,6 +21,8 @@ add_executable(poi
singleapplication.h
browser.cpp
browser.h
+ commandline.cpp
+ commandline.h
../data/resources.qrc
# main window
@@ -34,6 +36,8 @@ add_executable(poi
mainwindow/widgets/searchform.cpp
mainwindow/widgets/searchform.h
mainwindow/widgets/searchform.ui
+ mainwindow/widgets/tabbar.cpp
+ mainwindow/widgets/tabbar.h
# address bar
addressbar/completer.cpp
@@ -44,8 +48,6 @@ add_executable(poi
# todo: move all to mainwindow
widgets/mainwindowmenubar.cpp
widgets/mainwindowmenubar.h
- widgets/mainwindowtabbar.cpp
- widgets/mainwindowtabbar.h
# webengine
webengine/cookiefilter.cpp
@@ -58,6 +60,10 @@ add_executable(poi
webengine/webpage.h
webengine/webview.cpp
webengine/webview.h
+ webengine/widgets/pagetoolsmenu.cpp
+ webengine/widgets/pagetoolsmenu.h
+ webengine/widgets/pagemenu.cpp
+ webengine/widgets/pagemenu.h
# forms
forms/aboutdialog.cpp
@@ -69,7 +75,8 @@ add_executable(poi
#forms/cookiesform.ui
# plugin interfaces
- ../plugins/interfaces.h commandline.cpp commandline.h webengine/widgets/pagetoolsmenu.cpp webengine/widgets/pagetoolsmenu.h webengine/widgets/pagemenu.cpp webengine/widgets/pagemenu.h)
+ ../plugins/interfaces.h
+)
target_include_directories(poi
PRIVATE ../lib ../plugins