aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 0c6876d..cf66a53 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -58,7 +58,15 @@ target_link_libraries(poi
about
addressbar
configuration
- bookmarks downloads web)
+ bookmarks downloads web
+)
+
+if(Plasma)
+ target_link_libraries(poi KF5::WindowSystem)
+ target_compile_definitions(poi
+ PRIVATE PLASMA_BLUR # give the main window a translucent background and blur
+ )
+endif(Plasma)
target_compile_definitions(poi
PRIVATE QTBUG_65223_WORKAROUND