aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a44a44f..b772792 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -47,6 +47,10 @@ set(srclist
webengine/webview.cpp
webengine/webview.h
+ # wallet (form autofill)
+ wallet/wallet.cpp
+ wallet/wallet.h
+
# interfaces
${PROJECT_SOURCE_DIR}/include/plugininterface.h
${PROJECT_SOURCE_DIR}/include/profileinterface.h
@@ -92,10 +96,8 @@ if(Breakpad)
endif()
if(Plasma)
- target_link_libraries(${poi_exe} KF5::WindowSystem)
- target_compile_definitions(${poi_exe}
- PRIVATE PLASMA_BLUR # give the main window a translucent background and blur
- )
+ target_link_libraries(${poi_exe} KF5::Wallet KF5::WindowSystem)
+ target_compile_definitions(${poi_exe} PRIVATE PLASMA)
endif(Plasma)
target_compile_definitions(${poi_exe}