aboutsummaryrefslogtreecommitdiff
path: root/staging/adblock/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'staging/adblock/meson.build')
-rw-r--r--staging/adblock/meson.build15
1 files changed, 8 insertions, 7 deletions
diff --git a/staging/adblock/meson.build b/staging/adblock/meson.build
index fb92481..942f325 100644
--- a/staging/adblock/meson.build
+++ b/staging/adblock/meson.build
@@ -4,6 +4,11 @@ lib_adblockfilter = static_library('adblockfilter',
dependencies: [ dep_qt5 ]
)
+dep_adblockfilter = declare_dependency(
+ include_directories: ['.', smolbote_interfaces],
+ link_with: lib_adblockfilter
+)
+
#AdblockPlusFilterPlugin = shared_library('AdblockPlusPlugin',
# [ 'plugin/plugin.cpp',
# mod_qt5.preprocess(include_directories: smolbote_interfaces,
@@ -18,20 +23,16 @@ lib_adblockfilter = static_library('adblockfilter',
test('adblock: rule', executable('libadblockfilter_rule',
sources: 'test/rule.cpp',
- link_with: lib_adblockfilter,
- dependencies: [ dep_qt5, dep_catch ]
+ dependencies: [ dep_qt5, dep_catch, dep_adblockfilter ]
))
test('adblock: options', executable('libadblockfilter_options',
sources: 'test/options.cpp',
- link_with: lib_adblockfilter,
- dependencies: [ dep_qt5, dep_catch ]
+ dependencies: [ dep_qt5, dep_catch, dep_adblockfilter ]
))
test('adblock: filterlist', executable('libadblockfilter_filterlist',
sources: 'test/filterlist.cpp',
- include_directories: smolbote_interfaces,
- link_with: lib_adblockfilter,
- dependencies: [ dep_qt5, dep_catch ]
+ dependencies: [ dep_qt5, dep_catch, dep_adblockfilter ]
))