aboutsummaryrefslogtreecommitdiff
path: root/staging/adblock/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'staging/adblock/meson.build')
-rw-r--r--staging/adblock/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/staging/adblock/meson.build b/staging/adblock/meson.build
new file mode 100644
index 0000000..1fc4c65
--- /dev/null
+++ b/staging/adblock/meson.build
@@ -0,0 +1,16 @@
+dep_adblockfilter = declare_dependency(
+ include_directories: include_directories('.'),
+ link_with: static_library('adblockfilter',
+ [ 'filterlist.cpp', 'rule.cpp', 'options.cpp' ],
+ dependencies: dep_qt5
+ )
+)
+
+test('adblockfilter: parser',
+ executable('adblockfilter-parsefilter', dependencies: [ dep_qt5, dep_gtest, dep_adblockfilter ],
+ sources: [ 'test/parser.cpp' ]
+ ),
+ workdir: meson.current_source_dir() / 'test',
+ should_fail: true
+)
+