aboutsummaryrefslogtreecommitdiff
path: root/staging/hostlist/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'staging/hostlist/meson.build')
-rw-r--r--staging/hostlist/meson.build48
1 files changed, 16 insertions, 32 deletions
diff --git a/staging/hostlist/meson.build b/staging/hostlist/meson.build
index d37db1b..c5f3499 100644
--- a/staging/hostlist/meson.build
+++ b/staging/hostlist/meson.build
@@ -1,36 +1,20 @@
lib_hostlistfilter = static_library('hostlistfilter',
- ['filterlist.cpp'],
- include_directories
- : smolbote_interfaces,
- dependencies
- : [dep_qt5])
+ [ 'filterlist.cpp' ],
+ include_directories: smolbote_interfaces,
+ dependencies: [dep_qt5]
+)
- dep_hostlistfilter
- = declare_dependency(
- include_directories
- : ['.', smolbote_interfaces],
- link_with
- : lib_hostlistfilter)
+dep_hostlistfilter = declare_dependency(
+ include_directories: ['.', smolbote_interfaces],
+ link_with : lib_hostlistfilter
+)
-#AdblockPlusFilterPlugin = shared_library('AdblockPlusPlugin',
-#['plugin/plugin.cpp',
-#mod_qt5.preprocess(include_directories \
- : smolbote_interfaces,
-#moc_headers : 'plugin/plugin.h', dependencies : dep_qt5)
-#],
-#include_directories : smolbote_interfaces,
-#link_with : lib_adblockfilter,
-#dependencies : dep_qt5,
-#install : true,
-#install_dir : get_option('libdir') / 'smolbote/plugins'
-#)
+test('hostlist: rule parsing', executable('rule',
+ sources: 'test/rule.cpp',
+ dependencies: [dep_qt5, dep_catch, dep_hostlistfilter]))
- test('hostlist: rule parsing', executable('rule', sources
- : 'test/rule.cpp', dependencies
- : [dep_qt5, dep_catch, dep_hostlistfilter]))
-
- subdir_done()
-
- test('hostlist: filterlist', executable('filterlist', sources
- : 'test/filterlist.cpp', dependencies
- : [dep_qt5, dep_catch, dep_hostlistfilter]))
+test('hostlist: filterlist', executable('filterlist',
+ sources: 'test/filterlist.cpp',
+ dependencies: [dep_qt5, dep_catch, dep_hostlistfilter]),
+ env: 'HOSTLIST_TXT='+meson.current_source_dir()/'test/hostlist.txt'
+)