aboutsummaryrefslogtreecommitdiff
path: root/staging/smolblok/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'staging/smolblok/meson.build')
-rw-r--r--staging/smolblok/meson.build11
1 files changed, 4 insertions, 7 deletions
diff --git a/staging/smolblok/meson.build b/staging/smolblok/meson.build
index d563fcd..8ae0c74 100644
--- a/staging/smolblok/meson.build
+++ b/staging/smolblok/meson.build
@@ -1,18 +1,15 @@
dep_smolblok = declare_dependency(
include_directories: [ '.', smolbote_interfaces ],
link_with: library('smolblok',
- [
- 'filtermanager.cpp',
- ],
+ [ 'smolblok.cpp' ],
include_directories: smolbote_interfaces,
- dependencies: [ dep_qt5, dep_adblockfilter ]
+ dependencies: dep_qt5
)
)
test('smolblok', executable('filterlist',
- dependencies: [ dep_qt5, dep_smolblok ],
+ dependencies: [ dep_qt5, dep_catch, dep_smolblok ],
sources: [ 'test/main.cpp' ]
- ),
- args: files('test/sample-filters.txt')
+ )
)