aboutsummaryrefslogtreecommitdiff
path: root/staging/smolblok/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'staging/smolblok/meson.build')
-rw-r--r--staging/smolblok/meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/staging/smolblok/meson.build b/staging/smolblok/meson.build
new file mode 100644
index 0000000..d563fcd
--- /dev/null
+++ b/staging/smolblok/meson.build
@@ -0,0 +1,18 @@
+dep_smolblok = declare_dependency(
+ include_directories: [ '.', smolbote_interfaces ],
+ link_with: library('smolblok',
+ [
+ 'filtermanager.cpp',
+ ],
+ include_directories: smolbote_interfaces,
+ dependencies: [ dep_qt5, dep_adblockfilter ]
+ )
+)
+
+test('smolblok', executable('filterlist',
+ dependencies: [ dep_qt5, dep_smolblok ],
+ sources: [ 'test/main.cpp' ]
+ ),
+ args: files('test/sample-filters.txt')
+)
+