aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build37
1 files changed, 37 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..a388acd
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,37 @@
+project('args.hxx', ['cpp'],
+ version: '6.2.2',
+ default_options: 'cpp_std=c++11',
+ license: 'MIT'
+)
+
+# This is a header-only lib, all we need to do is include it
+args_dep = declare_dependency(
+ include_directories: include_directories('.')
+).as_system('system')
+
+install_headers('args.hxx')
+
+# examples
+if get_option('examples')
+executable('gitlike', sources: 'examples/gitlike.cxx', dependencies: args_dep)
+executable('completion', sources: 'examples/completion.cxx', dependencies: args_dep)
+endif
+
+# tests
+if get_option('unittests')
+test('argstest', executable('argstest',
+ sources: 'test.cxx',
+ dependencies: args_dep
+))
+
+test('argstest-multiple-inclusion', executable('argstest-multiple-inclusion',
+ sources: [ 'test/multiple_inclusion_1.cxx', 'test/multiple_inclusion_2.cxx' ],
+ dependencies: args_dep
+))
+
+test('argstest-windows-h', executable('argstest-windows-h',
+ sources: 'test/windows_h.cxx',
+ dependencies: args_dep
+))
+endif
+