aboutsummaryrefslogtreecommitdiff
path: root/com/BLAKE2/meson.build
diff options
context:
space:
mode:
authoraqua <aqua@iserlohn-fortress.net>2022-07-24 18:49:43 +0300
committeraqua <aqua@iserlohn-fortress.net>2022-12-28 21:01:39 +0200
commite5d541428e910a5df98728bc46d80a612603cf13 (patch)
treea5d0a9c497ff7b67ae60815a7450253023db6c05 /com/BLAKE2/meson.build
parentAdd test and valgrind targets to rules.mk (diff)
downloadkernel-e5d541428e910a5df98728bc46d80a612603cf13.tar.xz
Add BLAKE2s implementation
Diffstat (limited to 'com/BLAKE2/meson.build')
-rw-r--r--com/BLAKE2/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/com/BLAKE2/meson.build b/com/BLAKE2/meson.build
new file mode 100644
index 0000000..005a157
--- /dev/null
+++ b/com/BLAKE2/meson.build
@@ -0,0 +1,7 @@
+BLAKE2s = declare_dependency(
+ sources: 'blake2s.c',
+ compile_args: '-fanalyzer'
+)
+
+test('BLAKE2s functions', executable('b2s_fns', 'test_fns.c', dependencies: BLAKE2s, native: true), suite: 'BLAKE2')
+test('BLAKE2s selftest', executable('b2s_selftest', 'test_main.c', dependencies: BLAKE2s, native: true), suite: 'BLAKE2')