aboutsummaryrefslogtreecommitdiff
path: root/i686/meson.build
diff options
context:
space:
mode:
authoraqua <aqua@iserlohn-fortress.net>2022-10-29 11:26:44 +0300
committeraqua <aqua@iserlohn-fortress.net>2022-10-29 11:26:44 +0300
commitc4fcc92183c55db868d0d6ae53e6009fb2e53ee5 (patch)
treead5ef50aa07465e11f779c4482e20e6071182e9c /i686/meson.build
parentmakefile: add libk target (diff)
downloadkernel-c4fcc92183c55db868d0d6ae53e6009fb2e53ee5.tar.xz
makefile: add i686/arch.a target
Diffstat (limited to 'i686/meson.build')
-rw-r--r--i686/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/i686/meson.build b/i686/meson.build
new file mode 100644
index 0000000..f6bed8e
--- /dev/null
+++ b/i686/meson.build
@@ -0,0 +1,9 @@
+arch = declare_dependency(
+ sources: ['boot.S', 'init.s',
+ 'gdt.c', 'lgdt.c', 'lidt.c'
+ ],
+ include_directories: 'include',
+ compile_args: '-mgeneral-regs-only'
+)
+
+test('GDT', executable('gdt', ['test/gdt.c', 'gdt.c'], include_directories: 'include', native: true))