aboutsummaryrefslogtreecommitdiff
path: root/com/BLAKE2/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'com/BLAKE2/meson.build')
-rw-r--r--com/BLAKE2/meson.build7
1 files changed, 4 insertions, 3 deletions
diff --git a/com/BLAKE2/meson.build b/com/BLAKE2/meson.build
index 1592dd7..7d180e3 100644
--- a/com/BLAKE2/meson.build
+++ b/com/BLAKE2/meson.build
@@ -1,14 +1,15 @@
#BLAKE2s = static_library('BLAKE2s', 'blake2s.c')
BLAKE2s_native = shared_library('BLAKE2s_native', 'blake2s.c', native: true)
-test('BLAKE2s functions', executable('b2s_fns', 'test_fns.c', link_with: BLAKE2s_native, native: true), suite: 'BLAKE2')
-test('BLAKE2s selftest', executable('b2s_selftest', 'test_main.c', link_with: BLAKE2s_native, native: true), suite: 'BLAKE2')
-
kat = generator(python3,
arguments: '@INPUT@',
capture: true, output: '@BASENAME@.h'
)
+test('BLAKE2s selftest',
+ executable('b2s_selftest', 'test/blake2s_selftest.c', link_with: BLAKE2s_native, native: true),
+ suite: 'BLAKE2'
+)
test('BLAKE2s KAT',
executable('b2s_kat', ['test/blake2s_kat.c', kat.process('test/blake2s_kat.py')],
link_with: BLAKE2s_native, native: true),