aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 8279212..9896e66 100644
--- a/meson.build
+++ b/meson.build
@@ -1,5 +1,11 @@
-project('glitch kernel', 'c', version: '0.1.0', default_options: ['c_std=gnu11', 'warning_level=2'])
+project('glitch kernel', 'c', version: '0.0.0', default_options: ['c_std=gnu11', 'warning_level=2'])
python3 = import('python').find_installation('python3')
+cc = meson.get_compiler('c')
+
+conf = configuration_data()
+conf.set_quoted('VERSION', run_command(['git', 'describe', '--long'], capture: true, check: true).stdout().strip())
+conf.set_quoted('CC', cc.get_id() + ' ' + cc.version())
+configure_file(output: 'conf.h', configuration: conf)
subdir('arch/i686')
subdir('devices')