summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2021-03-07 10:34:31 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2021-03-07 10:34:42 +0200
commitb28bd46f46f3023bc67d031b379c2fd47c64ef14 (patch)
tree86ce63421c124a9b32254be51d2803c60e62f1a1
downloaddevilutionX-b28bd46f46f3023bc67d031b379c2fd47c64ef14.tar.xz
Initial commit (v1.1.0)
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..933c6e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: aqua <aqua@iserlohn-fortress.net>
+
+pkgname=devilutionX
+pkgdesc='Diablo build for modern operating systems'
+license=('Unlicense')
+pkgver=1.1.0
+pkgrel=0
+
+depends=('sdl2' 'sdl2_mixer' 'sdl2_ttf')
+arch=('x86_64')
+
+url='https://github.com/diasurgical/devilutionX'
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
+ )
+sha512sums=('341e7f2e74e7af4a7b42054b58b6518c2f286f2fdcb21c5553a15912c044ea08f6c7b07a2079e7e795a5146e7a301789fe32b6fda5ff9fbec0654d886d423b38')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cd build
+ cmake -DBINARY_RELEASE=ON -DNONET=ON -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver/build"
+ make DESTDIR="$pkgdir" install
+}