summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2019-02-18 17:41:18 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2019-02-18 17:41:18 +0200
commitf1acdc9c3a8dfa70163dbf2d43c8f7d0b72051f0 (patch)
treeb315a263b9f0a121c75cf0a4ba4034dd917bf97a
downloadlinenoise-git-f1acdc9c3a8dfa70163dbf2d43c8f7d0b72051f0.tar.xz
Initial commitHEADmaster
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..4c48ccf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Aqua-sama <aqua@iserlohn-fortress.net>
+
+pkgname=linenoise-ng
+pkgdesc='A small self-contained alternative to readline and libedit that support UTF-8 and Windows and is BSD licensed'
+
+pkgver=1.0.1
+pkgrel=1
+
+url="https://github.com/arangodb/linenoise-ng"
+
+arch=('x86_64')
+license=('BSD-3clause')
+
+depends=()
+optdepends=()
+makedepends=('cmake')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/arangodb/linenoise-ng/archive/v$pkgver.tar.gz")
+sha512sums=('f5d0e83d750ce81dd86cf470a894c18e1c72576d312f84c1a486662506d9ca79bc987939fd7c7a283511951f7e18af19091320623b4ad5a3c939c539f5c8e9e3')
+
+build() {
+ cd $pkgname-$pkgver
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release ..
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver/build
+ make DESTDIR="$pkgdir" install
+}
+