summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2020-07-02 11:23:58 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2020-07-02 11:23:58 -0700
commit2bf5f7d7aa88c4a37126fbcf65d509e0eccfbfeb (patch)
treed43342858f0e0728bbb6ef62281c2fcacbb54322
parentDisabled psi, kvm werror, scheduler debug, and latencytop again (diff)
downloadlinux-ck-2bf5f7d7aa88c4a37126fbcf65d509e0eccfbfeb.tar.xz
Updated to 5.7.7
-rw-r--r--0002-PCI-EDR-Log-only-ACPI_NOTIFY_DISCONNECT_RECOVER-even.patch38
-rw-r--r--0002-efi-libstub-Fix-path-separator-regression.patch54
-rw-r--r--0003-ALSA-usb-audio-Fix-packet-size-calculation.patch35
-rw-r--r--0004-drm-amd-display-Only-revalidate-bandwidth-on-medium-.patch42
-rw-r--r--PKGBUILD18
5 files changed, 127 insertions, 60 deletions
diff --git a/0002-PCI-EDR-Log-only-ACPI_NOTIFY_DISCONNECT_RECOVER-even.patch b/0002-PCI-EDR-Log-only-ACPI_NOTIFY_DISCONNECT_RECOVER-even.patch
new file mode 100644
index 0000000..1631d9a
--- /dev/null
+++ b/0002-PCI-EDR-Log-only-ACPI_NOTIFY_DISCONNECT_RECOVER-even.patch
@@ -0,0 +1,38 @@
+From 6535fe9061b6f1ce76ac658ae34b85fb3ed38ad9 Mon Sep 17 00:00:00 2001
+From: Kuppuswamy Sathyanarayanan <sathyanarayanan.kuppuswamy@linux.intel.com>
+Date: Wed, 15 Apr 2020 17:38:32 -0700
+Subject: PCI/EDR: Log only ACPI_NOTIFY_DISCONNECT_RECOVER events
+
+Previously we logged *all* ACPI SYSTEM-level events, which may include lots
+of non-EDR events. Move the message so we only log those related to EDR.
+
+Link: https://lore.kernel.org/r/01afb4e01efbe455de0c445bef6cf3ffc59340d2.1586996350.git.sathyanarayanan.kuppuswamy@linux.intel.com
+[bhelgaas: drop the pci_dbg() of all events since ACPI can log those
+already]
+Signed-off-by: Kuppuswamy Sathyanarayanan <sathyanarayanan.kuppuswamy@linux.intel.com>
+Signed-off-by: Bjorn Helgaas <bhelgaas@google.com>
+---
+ drivers/pci/pcie/edr.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/drivers/pci/pcie/edr.c b/drivers/pci/pcie/edr.c
+index 594622a6cb16..a6b9b479b97a 100644
+--- a/drivers/pci/pcie/edr.c
++++ b/drivers/pci/pcie/edr.c
+@@ -148,11 +148,11 @@ static void edr_handle_event(acpi_handle handle, u32 event, void *data)
+ pci_ers_result_t estate = PCI_ERS_RESULT_DISCONNECT;
+ u16 status;
+
+- pci_info(pdev, "ACPI event %#x received\n", event);
+-
+ if (event != ACPI_NOTIFY_DISCONNECT_RECOVER)
+ return;
+
++ pci_info(pdev, "EDR event received\n");
++
+ /* Locate the port which issued EDR event */
+ edev = acpi_dpc_port_get(pdev);
+ if (!edev) {
+--
+cgit v1.2.3-1-gf6bb5
+
diff --git a/0002-efi-libstub-Fix-path-separator-regression.patch b/0002-efi-libstub-Fix-path-separator-regression.patch
deleted file mode 100644
index ad780ee..0000000
--- a/0002-efi-libstub-Fix-path-separator-regression.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From 2eff8033714ddf05bb2fe52003921af8c8839ed2 Mon Sep 17 00:00:00 2001
-From: Philipp Fent <fent@in.tum.de>
-Date: Mon, 15 Jun 2020 13:51:09 +0200
-Subject: efi/libstub: Fix path separator regression
-
-Commit 9302c1bb8e47 ("efi/libstub: Rewrite file I/O routine") introduced a
-regression that made a couple of (badly configured) systems fail to
-boot [1]: Until 5.6, we silently accepted Unix-style file separators in
-EFI paths, which might violate the EFI standard, but are an easy to make
-mistake. This fix restores the pre-5.7 behaviour.
-
-[1] https://bbs.archlinux.org/viewtopic.php?id=256273
-
-Fixes: 9302c1bb8e47 ("efi/libstub: Rewrite file I/O routine")
-Signed-off-by: Philipp Fent <fent@in.tum.de>
-Link: https://lore.kernel.org/r/20200615115109.7823-1-fent@in.tum.de
-[ardb: rewrite as chained if/else statements]
-Signed-off-by: Ard Biesheuvel <ardb@kernel.org>
----
- drivers/firmware/efi/libstub/file.c | 16 ++++++++++++----
- 1 file changed, 12 insertions(+), 4 deletions(-)
-
-diff --git a/drivers/firmware/efi/libstub/file.c b/drivers/firmware/efi/libstub/file.c
-index ea66b1f16a79..f1c4faf58c76 100644
---- a/drivers/firmware/efi/libstub/file.c
-+++ b/drivers/firmware/efi/libstub/file.c
-@@ -104,12 +104,20 @@ static int find_file_option(const efi_char16_t *cmdline, int cmdline_len,
- if (!found)
- return 0;
-
-+ /* Skip any leading slashes */
-+ while (cmdline[i] == L'/' || cmdline[i] == L'\\')
-+ i++;
-+
- while (--result_len > 0 && i < cmdline_len) {
-- if (cmdline[i] == L'\0' ||
-- cmdline[i] == L'\n' ||
-- cmdline[i] == L' ')
-+ efi_char16_t c = cmdline[i++];
-+
-+ if (c == L'\0' || c == L'\n' || c == L' ')
- break;
-- *result++ = cmdline[i++];
-+ else if (c == L'/')
-+ /* Replace UNIX dir separators with EFI standard ones */
-+ *result++ = L'\\';
-+ else
-+ *result++ = c;
- }
- *result = L'\0';
- return i;
---
-cgit v1.2.3-1-gf6bb5
-
diff --git a/0003-ALSA-usb-audio-Fix-packet-size-calculation.patch b/0003-ALSA-usb-audio-Fix-packet-size-calculation.patch
new file mode 100644
index 0000000..b75ab48
--- /dev/null
+++ b/0003-ALSA-usb-audio-Fix-packet-size-calculation.patch
@@ -0,0 +1,35 @@
+From 17c5f7dd425becd30c4a2dafaecb054641a1fdc9 Mon Sep 17 00:00:00 2001
+From: Alexander Tsoy <alexander@tsoy.me>
+Date: Mon, 29 Jun 2020 05:59:33 +0300
+Subject: ALSA: usb-audio: Fix packet size calculation
+
+Commit f0bd62b64016 ("ALSA: usb-audio: Improve frames size computation")
+introduced a regression for devices which have playback endpoints with
+bInterval > 1. Fix this by taking ep->datainterval into account.
+
+Note that frame and fps are actually mean packet and packets per second
+in the code introduces by the mentioned commit. This will be fixed in a
+follow-up patch.
+
+Fixes: f0bd62b64016 ("ALSA: usb-audio: Improve frames size computation")
+BugLink: https://bugzilla.kernel.org/show_bug.cgi?id=208353
+Signed-off-by: Alexander Tsoy <alexander@tsoy.me>
+---
+ sound/usb/endpoint.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/sound/usb/endpoint.c b/sound/usb/endpoint.c
+index 9bea7d3f99f8..11f23778f0a5 100644
+--- a/sound/usb/endpoint.c
++++ b/sound/usb/endpoint.c
+@@ -1093,6 +1093,7 @@ int snd_usb_endpoint_set_params(struct snd_usb_endpoint *ep,
+ ep->freqn = get_usb_high_speed_rate(rate);
+ ep->fps = 8000;
+ }
++ ep->fps >>= ep->datainterval;
+
+ ep->sample_rem = rate % ep->fps;
+ ep->framesize[0] = rate / ep->fps;
+--
+cgit v1.2.3-1-gf6bb5
+
diff --git a/0004-drm-amd-display-Only-revalidate-bandwidth-on-medium-.patch b/0004-drm-amd-display-Only-revalidate-bandwidth-on-medium-.patch
new file mode 100644
index 0000000..2cce397
--- /dev/null
+++ b/0004-drm-amd-display-Only-revalidate-bandwidth-on-medium-.patch
@@ -0,0 +1,42 @@
+From 7fab9d4206e54d19b578c70cd0529045ad642f25 Mon Sep 17 00:00:00 2001
+From: Nicholas Kazlauskas <nicholas.kazlauskas@amd.com>
+Date: Mon, 29 Jun 2020 13:03:52 -0400
+Subject: drm/amd/display: Only revalidate bandwidth on medium and fast updates
+
+[Why]
+Changes that are fast don't require updating DLG parameters making
+this call unnecessary. Considering this is an expensive call it should
+not be done on every flip.
+
+[How]
+Guard the validation to only happen if update type isn't FAST.
+
+Signed-off-by: Nicholas Kazlauskas <nicholas.kazlauskas@amd.com>
+---
+ drivers/gpu/drm/amd/display/dc/core/dc.c | 10 ++++++----
+ 1 file changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/drivers/gpu/drm/amd/display/dc/core/dc.c b/drivers/gpu/drm/amd/display/dc/core/dc.c
+index 4acaf4be8a81..c825d383f0f1 100644
+--- a/drivers/gpu/drm/amd/display/dc/core/dc.c
++++ b/drivers/gpu/drm/amd/display/dc/core/dc.c
+@@ -2533,10 +2533,12 @@ void dc_commit_updates_for_stream(struct dc *dc,
+
+ copy_stream_update_to_stream(dc, context, stream, stream_update);
+
+- if (!dc->res_pool->funcs->validate_bandwidth(dc, context, false)) {
+- DC_ERROR("Mode validation failed for stream update!\n");
+- dc_release_state(context);
+- return;
++ if (update_type > UPDATE_TYPE_FAST) {
++ if (!dc->res_pool->funcs->validate_bandwidth(dc, context, false)) {
++ DC_ERROR("Mode validation failed for stream update!\n");
++ dc_release_state(context);
++ return;
++ }
+ }
+
+ commit_planes_for_stream(
+--
+cgit v1.2.3-1-gf6bb5
+
diff --git a/PKGBUILD b/PKGBUILD
index 980c50e..5ba8f91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@ _custom=1
pkgbase=linux-ck
_supver=5
_majver=7
-_minver=6
+_minver=7
_gccpatchver='20200615'
_gccpatchger='10.1'
_gccpatchker='5.7'
@@ -31,7 +31,7 @@ _ckpatchversion=ck1
else
pkgver=${_supver}.${_majver}.${_minver}
fi
-pkgrel=1.3
+pkgrel=1
pkgdesc='Linux-ck'
url='https://kernel.org'
#url='http://ck.kolivas.org/patches/'
@@ -46,7 +46,9 @@ _srcname=linux-${pkgver}
source=(
https://www.kernel.org/pub/linux/kernel/v${_supver}.x/${_srcname}.tar.{xz,sign}
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
- 0002-efi-libstub-Fix-path-separator-regression.patch
+ 0002-PCI-EDR-Log-only-ACPI_NOTIFY_DISCONNECT_RECOVER-even.patch
+ 0003-ALSA-usb-audio-Fix-packet-size-calculation.patch
+ 0004-drm-amd-display-Only-revalidate-bandwidth-on-medium-.patch
linux-ck-patch-${_supver}.${_majver}-${_ckpatchversion}.xz::http://ck.kolivas.org/patches/${_supver}.0/${_supver}.${_majver}/${_supver}.${_majver}-${_ckpatchversion}/patch-${_supver}.${_majver}-${_ckpatchversion}.xz
kernel_gcc_patch-${_gccpatchver}.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/${_gccpatchver}.tar.gz
ath9k-regdom-hack.patch
@@ -60,10 +62,12 @@ validpgpkeys=(
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
# https://www.kernel.org/pub/linux/kernel/v5.x/sha256sums.asc
-b2sums=('6f85bbef8ed4db5214c71fcc32e4793ee336f635ff385f5208a3eb8f45e5201b9acb40db2e0e51514a2d95269336208ab6156cf695c7f4ceb8df6b537dd0cab6'
+b2sums=('0bd13b75dba824231903ce5542936c911661b5fe54f565cfb3fc31cde96d1557d543367f232fac8c8ecec65a065dd843bd7a55fb67d9dd8abfae3074808520c7'
'SKIP'
'ab1fb19c67d4c107f75767581c33d9c1458b4d9fdb88f4adb41d30a36f5a2f95f1c48ef079eb87e1e6e8ce2f98b293195cb2c0f2a8ec975aa817453289158c6e'
- '3bb69cc581164cfdc416198b8a1d3d905d98e7f0f6f739d68a0c19d697e76545230f9e224d08e09c15d0ea3126a73608b56dbfa852892462bc11ef9dac525811'
+ '490c7d188215f1d24b5807a744853fa308c2cd17c9eb8668918a50a0c58cab9cbc9ee13ac9abbb614eb010a4a56e9092fea4440d44c80c8e67f2d9abdf19a83f'
+ 'c080582b285af6b08f004e49ff4b96a074ad455b91688bc06a96bd6cfe422e6d270e7157f95cb7ad9a6b0fd47e07f2b1ec06f7f275591d22c958de4077a28b87'
+ '49ddc76376ec49e099089d7f87e5f566524ccf1b1ac7acf8353a3f0a4abdd1ee1108b99860f99fd0f55cfcd8c1149fb9aa2467449ebff2cb251b8466349b95bc'
'29b2530e91a7c0f75c47d75361a94ec92fec398cef1b3e213e97c8f9e0ed210711c4c63ae7717f59273105a83e30397cbd5b7252cb94c06d9b328a24c70ad444'
'c8d0697f99fe6105815217b8ec059d8f587415ea8dd2b88a65e1087feedf697341a64cd56810fde9e7aeada79125fc8235faccc7e7b06492c099e27a8abbe99c'
'2e58bb89b247b1678355368956e67c1de51fcde97a227b2162f6771e30f17fa5520faafe7be4b6816a542e7ae10d05f64c6b6354f352c12746d4b8da632936dd'
@@ -89,7 +93,9 @@ prepare() {
# Hotfixes
echo "Applying hotfixes"
patch -p1 -i ../0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
- patch -p1 -i ../0002-efi-libstub-Fix-path-separator-regression.patch
+ patch -p1 -i ../0002-PCI-EDR-Log-only-ACPI_NOTIFY_DISCONNECT_RECOVER-even.patch
+ patch -p1 -i ../0003-ALSA-usb-audio-Fix-packet-size-calculation.patch
+ patch -p1 -i ../0004-drm-amd-display-Only-revalidate-bandwidth-on-medium-.patch
patch -p1 -i ../sphinx-workaround.patch