summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2020-08-10 19:06:46 +0300
committerAqua-sama <aqua@iserlohn-fortress.net>2020-08-10 19:06:46 +0300
commit2d23f2276495fb53be822f54c658e2cda0e5652d (patch)
tree0a24e7c189bc68f025c842e987271a382cbc51f7
parentUpdated to 5.7.13 (diff)
downloadlinux-ck-2d23f2276495fb53be822f54c658e2cda0e5652d.tar.xz
Updated to 5.7.14
-rw-r--r--PKGBUILD9
-rw-r--r--unscrew-ck1_for_5.7.14.patch13
2 files changed, 19 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc9e6f8..186936a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@ _custom=1
pkgbase=linux-ck
_supver=5
_majver=7
-_minver=13
+_minver=14
_gccpatchver='20200615'
_gccpatchger='10.1'
_gccpatchker='5.7'
@@ -56,13 +56,14 @@ source=(
sphinx-workaround.patch
unscrew-ck1.patch::https://github.com/ckolivas/linux/commit/0b69e633d6b0b08ae8547dc4099c8c0985019553.patch
unscrew-ck1-fix-suspend-to-ram.patch::https://github.com/zen-kernel/zen-kernel/commit/fb7e2cfaf61cf5f9c2336331e73296f455bd2d51.patch
+ unscrew-ck1_for_5.7.14.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
# https://www.kernel.org/pub/linux/kernel/v5.x/sha256sums.asc
-b2sums=('8999dcaa23bf6c07e456b8fcb4b8d07a621737e72eb4f69db02b07bde0a3e73131019751d1c257434ef7380c583a914f5b81d802b82103800f6b44bde0ba4439'
+b2sums=('80e7c0d398f76d136463572ad435b444a9a0dc92a6d548ad4a13dc65fde7719adc7fc35e1e2e0319a8b0c61187f33007bec69ead2c01dd0b176803e913718ecc'
'SKIP'
'ab1fb19c67d4c107f75767581c33d9c1458b4d9fdb88f4adb41d30a36f5a2f95f1c48ef079eb87e1e6e8ce2f98b293195cb2c0f2a8ec975aa817453289158c6e'
'490c7d188215f1d24b5807a744853fa308c2cd17c9eb8668918a50a0c58cab9cbc9ee13ac9abbb614eb010a4a56e9092fea4440d44c80c8e67f2d9abdf19a83f'
@@ -74,7 +75,8 @@ b2sums=('8999dcaa23bf6c07e456b8fcb4b8d07a621737e72eb4f69db02b07bde0a3e7313101975
'4c6da586168ebc0892146146221919c49091c6298cdc653b9ce9547924f08427d592aa4c95ba75760aecb77c8157e18fd95a8b83a1cc6f9e1c80e6832aaa5fe7'
'b4e1377d97ad7e8144d6e55b6d43731e3271a5aec65b65ca6d81026a95f15f549b9303fb3c6f492099ca691e3f65f4cf7f0c3aa742df03b396d7f6d81813aa95'
'84c9438120100bb5b21122a29344b9e818514d94a31b6d57519a6e25385cb7f91a7f87c930da55c828c7a4330959a94b8a3a3d56773c46b335e1380cd00180b1'
- '5dfb38f2096f27cf436afa6ac41d432f4e23295deb26d12146b31c57db85a8be59819f08f9c5197183c26c557b32e967edded22206c1abb9b89b83e61450ec5c')
+ '5dfb38f2096f27cf436afa6ac41d432f4e23295deb26d12146b31c57db85a8be59819f08f9c5197183c26c557b32e967edded22206c1abb9b89b83e61450ec5c'
+ '101954510585f61fb7a4ab802bdcad26927224d840c10675189b5bd48d141d78caea152863c6ad5140d5933d2215d959cd868a61c06076b749fe36b94dcb17b1')
#export KBUILD_BUILD_HOST=arc4linux
export KBUILD_BUILD_USER=$pkgbase
@@ -102,6 +104,7 @@ prepare() {
# ck patch
echo "Applying ck patch"
+ patch -Np1 -i ../unscrew-ck1_for_5.7.14.patch ../linux-ck-patch-5.7-ck1
patch -F 3 -Np1 -i ../linux-ck-patch-${_supver}.${_majver}-${_ckpatchversion}
# ck hotfix
diff --git a/unscrew-ck1_for_5.7.14.patch b/unscrew-ck1_for_5.7.14.patch
new file mode 100644
index 0000000..c443634
--- /dev/null
+++ b/unscrew-ck1_for_5.7.14.patch
@@ -0,0 +1,13 @@
+--- a/linux-ck-patch-5.7-ck1
++++ b/linux-ck-patch-5.7-ck1
+@@ -12805,9 +12805,9 @@ index a5221abb4594..9a9287cb2a37 100644
+ --- a/kernel/time/timer.c
+ +++ b/kernel/time/timer.c
+ @@ -43,6 +43,7 @@
+- #include <linux/sched/debug.h>
+ #include <linux/slab.h>
+ #include <linux/compat.h>
++ #include <linux/random.h>
+ +#include <linux/freezer.h>
+
+ #include <linux/uaccess.h>