summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2020-06-25 18:19:09 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2020-06-25 18:19:09 -0700
commit97ab33af0e131102d29bbbaca0812efffc793905 (patch)
treea81539e04ab66fe4130f19cff9a93637ff3c92bf
parentUpdated to 5.7.5 (diff)
downloadlinux-ck-97ab33af0e131102d29bbbaca0812efffc793905.tar.xz
Updated to 5.7.6
Added hotfix
-rw-r--r--0002-efi-libstub-Fix-path-separator-regression.patch54
-rw-r--r--PKGBUILD11
-rw-r--r--config4
3 files changed, 64 insertions, 5 deletions
diff --git a/0002-efi-libstub-Fix-path-separator-regression.patch b/0002-efi-libstub-Fix-path-separator-regression.patch
new file mode 100644
index 0000000..ad780ee
--- /dev/null
+++ b/0002-efi-libstub-Fix-path-separator-regression.patch
@@ -0,0 +1,54 @@
+From 2eff8033714ddf05bb2fe52003921af8c8839ed2 Mon Sep 17 00:00:00 2001
+From: Philipp Fent <fent@in.tum.de>
+Date: Mon, 15 Jun 2020 13:51:09 +0200
+Subject: efi/libstub: Fix path separator regression
+
+Commit 9302c1bb8e47 ("efi/libstub: Rewrite file I/O routine") introduced a
+regression that made a couple of (badly configured) systems fail to
+boot [1]: Until 5.6, we silently accepted Unix-style file separators in
+EFI paths, which might violate the EFI standard, but are an easy to make
+mistake. This fix restores the pre-5.7 behaviour.
+
+[1] https://bbs.archlinux.org/viewtopic.php?id=256273
+
+Fixes: 9302c1bb8e47 ("efi/libstub: Rewrite file I/O routine")
+Signed-off-by: Philipp Fent <fent@in.tum.de>
+Link: https://lore.kernel.org/r/20200615115109.7823-1-fent@in.tum.de
+[ardb: rewrite as chained if/else statements]
+Signed-off-by: Ard Biesheuvel <ardb@kernel.org>
+---
+ drivers/firmware/efi/libstub/file.c | 16 ++++++++++++----
+ 1 file changed, 12 insertions(+), 4 deletions(-)
+
+diff --git a/drivers/firmware/efi/libstub/file.c b/drivers/firmware/efi/libstub/file.c
+index ea66b1f16a79..f1c4faf58c76 100644
+--- a/drivers/firmware/efi/libstub/file.c
++++ b/drivers/firmware/efi/libstub/file.c
+@@ -104,12 +104,20 @@ static int find_file_option(const efi_char16_t *cmdline, int cmdline_len,
+ if (!found)
+ return 0;
+
++ /* Skip any leading slashes */
++ while (cmdline[i] == L'/' || cmdline[i] == L'\\')
++ i++;
++
+ while (--result_len > 0 && i < cmdline_len) {
+- if (cmdline[i] == L'\0' ||
+- cmdline[i] == L'\n' ||
+- cmdline[i] == L' ')
++ efi_char16_t c = cmdline[i++];
++
++ if (c == L'\0' || c == L'\n' || c == L' ')
+ break;
+- *result++ = cmdline[i++];
++ else if (c == L'/')
++ /* Replace UNIX dir separators with EFI standard ones */
++ *result++ = L'\\';
++ else
++ *result++ = c;
+ }
+ *result = L'\0';
+ return i;
+--
+cgit v1.2.3-1-gf6bb5
+
diff --git a/PKGBUILD b/PKGBUILD
index 9a1adec..ce6b65e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@ _custom=1
pkgbase=linux-ck
_supver=5
_majver=7
-_minver=5
+_minver=6
_gccpatchver='20200615'
_gccpatchger='10.1'
_gccpatchker='5.7'
@@ -31,7 +31,7 @@ _ckpatchversion=ck1
else
pkgver=${_supver}.${_majver}.${_minver}
fi
-pkgrel=1
+pkgrel=1.2
pkgdesc='Linux-ck'
url='https://kernel.org'
#url='http://ck.kolivas.org/patches/'
@@ -46,6 +46,7 @@ _srcname=linux-${pkgver}
source=(
https://www.kernel.org/pub/linux/kernel/v${_supver}.x/${_srcname}.tar.{xz,sign}
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
+ 0002-efi-libstub-Fix-path-separator-regression.patch
linux-ck-patch-${_supver}.${_majver}-${_ckpatchversion}.xz::http://ck.kolivas.org/patches/${_supver}.0/${_supver}.${_majver}/${_supver}.${_majver}-${_ckpatchversion}/patch-${_supver}.${_majver}-${_ckpatchversion}.xz
kernel_gcc_patch-${_gccpatchver}.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/${_gccpatchver}.tar.gz
ath9k-regdom-hack.patch
@@ -59,14 +60,15 @@ validpgpkeys=(
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
# https://www.kernel.org/pub/linux/kernel/v5.x/sha256sums.asc
-b2sums=('8b2bcb3c11a5bee4cef117dab558b82f06e818ec9d66cbb567b9d9118ac657f168eea84d5bbd67c9fd579f7537177e184b4d23e32a8314e4860c31b68ad3a923'
+b2sums=('6f85bbef8ed4db5214c71fcc32e4793ee336f635ff385f5208a3eb8f45e5201b9acb40db2e0e51514a2d95269336208ab6156cf695c7f4ceb8df6b537dd0cab6'
'SKIP'
'ab1fb19c67d4c107f75767581c33d9c1458b4d9fdb88f4adb41d30a36f5a2f95f1c48ef079eb87e1e6e8ce2f98b293195cb2c0f2a8ec975aa817453289158c6e'
+ '3bb69cc581164cfdc416198b8a1d3d905d98e7f0f6f739d68a0c19d697e76545230f9e224d08e09c15d0ea3126a73608b56dbfa852892462bc11ef9dac525811'
'29b2530e91a7c0f75c47d75361a94ec92fec398cef1b3e213e97c8f9e0ed210711c4c63ae7717f59273105a83e30397cbd5b7252cb94c06d9b328a24c70ad444'
'c8d0697f99fe6105815217b8ec059d8f587415ea8dd2b88a65e1087feedf697341a64cd56810fde9e7aeada79125fc8235faccc7e7b06492c099e27a8abbe99c'
'2e58bb89b247b1678355368956e67c1de51fcde97a227b2162f6771e30f17fa5520faafe7be4b6816a542e7ae10d05f64c6b6354f352c12746d4b8da632936dd'
'fde132f3705d908e6f2147c78a2193289916d72304ca5efa2229d79fc3e57a857314ce94e71425caef2f7f7b6cf87f05ef86335dc8bd4be78e7035afe608005a'
- 'bce4fd3a790c9937fd0db02b9cd9fcb9c2f364c2694441c7ce45a65a163a40870a56d02fcddd6b1a63e03e76cec203a649570949cc4ddc8f18f3e08e22801be7'
+ '816a1321c59d8db4384c194e9a7a4b0bdcfa9b7115dca6d827f8a2d245e78ad47821b39d094709842d6ac273d5a077dbf52f4d5976fd9fe06a5f02e9f292ba22'
'b4e1377d97ad7e8144d6e55b6d43731e3271a5aec65b65ca6d81026a95f15f549b9303fb3c6f492099ca691e3f65f4cf7f0c3aa742df03b396d7f6d81813aa95'
'84c9438120100bb5b21122a29344b9e818514d94a31b6d57519a6e25385cb7f91a7f87c930da55c828c7a4330959a94b8a3a3d56773c46b335e1380cd00180b1')
@@ -87,6 +89,7 @@ prepare() {
# Hotfixes
echo "Applying hotfixes"
patch -p1 -i ../0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
+ patch -p1 -i ../0002-efi-libstub-Fix-path-separator-regression.patch
patch -p1 -i ../sphinx-workaround.patch
diff --git a/config b/config
index a23952f..30f610d 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.7.1 Kernel Configuration
+# Linux/x86 5.7.6 Kernel Configuration
#
#
@@ -8482,6 +8482,8 @@ CONFIG_HWSPINLOCK=y
#
# Clock Source drivers
#
+CONFIG_TIMER_OF=y
+CONFIG_TIMER_PROBE=y
CONFIG_CLKEVT_I8253=y
CONFIG_I8253_LOCK=y
CONFIG_CLKBLD_I8253=y