summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBin Jin <bjin1990@gmail.com>2016-01-09 16:18:00 +0000
committerBin Jin <bjin1990@gmail.com>2016-01-09 17:18:00 +0100
commit05a4db48324ecfe9e524761cb7115aeb15ea4706 (patch)
tree59b7db6c3bbeacbb160ec0441d7644e98476caa4
parentAdd optdepends back (diff)
downloadzfs-dkms-05a4db48324ecfe9e524761cb7115aeb15ea4706.tar.xz
Bump version
Also update to install from tarball release file instead of git. Remove unnecessary makedep, depends with exact version number should be enough.
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD24
3 files changed, 23 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b37dc6a..740865b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,27 @@
# Generated by mksrcinfo v8
-# Wed Dec 30 04:32:22 UTC 2015
+# Sat Jan 9 16:09:02 UTC 2016
pkgbase = zfs-dkms
- pkgver = 0.6.5.3
- pkgrel = 2
+ pkgver = 0.6.5.4
+ pkgrel = 1
url = http://zfsonlinux.org/
arch = i686
arch = x86_64
license = CDDL
makedepends = git
- makedepends = spl-dkms=0.6.5.3
- source = git+https://github.com/zfsonlinux/zfs.git#tag=zfs-0.6.5.3
+ source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.6.5.4/zfs-0.6.5.4.tar.gz
source = zfs-utils.bash-completion-r1
source = zfs-utils.initcpio.install
source = zfs-utils.initcpio.hook
- md5sums = SKIP
- md5sums = 9ddb0c8a94861f929d0fa741fdc49950
- md5sums = 9ef4841abb85dee611828cc7e6f5c6fe
- md5sums = 62ba32c6853c315ff231c396cf8bfdbb
+ sha256sums = 780862ec2301ccace412a324787e9df762cff6046e73e2ac0ebdce9e2bd59b0f
+ sha256sums = b60214f70ffffb62ffe489cbfabd2e069d14ed2a391fac0e36f914238394b540
+ sha256sums = 1e20071fa61a33874505dae0f2d71bb560f43e7faaea735cbde770ea10c133df
+ sha256sums = 250f1232c464a81cc9c8b8ee05f21d752ebeebbc8614fae1c6d0bc600e816ac1
pkgname = zfs-dkms
pkgdesc = Kernel modules for the Zettabyte File System.
install = zfs.install
- depends = spl-dkms=0.6.5.3
- depends = zfs-utils=0.6.5.3-2
+ depends = spl-dkms=0.6.5.4
+ depends = zfs-utils=0.6.5.4-1
depends = dkms
optdepends = mkinitcpio-dkms: Generate initramfs with zfs modules automatically
provides = zfs
diff --git a/.gitignore b/.gitignore
index bde5de2..979c9f9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
/src
/pkg
*.pkg*
+zfs-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 373c262..a0a9a7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,23 +5,23 @@
pkgbase="zfs-dkms"
pkgname=("zfs-dkms" "zfs-utils")
-pkgver=0.6.5.3
-pkgrel=2
+pkgver=0.6.5.4
+pkgrel=1
license=('CDDL')
-makedepends=("git" "spl-dkms=${pkgver}")
+makedepends=("git")
arch=("i686" "x86_64")
url="http://zfsonlinux.org/"
-source=("git+https://github.com/zfsonlinux/zfs.git#tag=zfs-${pkgver}"
+source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-${pkgver}/zfs-${pkgver}.tar.gz"
"zfs-utils.bash-completion-r1"
"zfs-utils.initcpio.install"
"zfs-utils.initcpio.hook")
-md5sums=('SKIP'
- '9ddb0c8a94861f929d0fa741fdc49950'
- '9ef4841abb85dee611828cc7e6f5c6fe'
- '62ba32c6853c315ff231c396cf8bfdbb')
+sha256sums=('780862ec2301ccace412a324787e9df762cff6046e73e2ac0ebdce9e2bd59b0f'
+ 'b60214f70ffffb62ffe489cbfabd2e069d14ed2a391fac0e36f914238394b540'
+ '1e20071fa61a33874505dae0f2d71bb560f43e7faaea735cbde770ea10c133df'
+ '250f1232c464a81cc9c8b8ee05f21d752ebeebbc8614fae1c6d0bc600e816ac1')
build() {
- cd "${srcdir}/zfs"
+ cd "${srcdir}/zfs-${pkgver}"
./autogen.sh
./configure --prefix=/usr \
@@ -48,8 +48,8 @@ package_zfs-dkms() {
dkmsdir="${pkgdir}/usr/src/zfs-${pkgver}"
install -d "${dkmsdir}"
- cd "${srcdir}/zfs"
- git archive --format=tar HEAD | tar -x -C "${dkmsdir}"
+ cd "${srcdir}"
+ tar -xzf "zfs-${pkgver}.tar.gz" -C "${dkmsdir}" --strip-components 1
cd "${dkmsdir}"
./autogen.sh
@@ -61,7 +61,7 @@ package_zfs-utils() {
pkgdesc="Kernel module support files for the Zettabyte File System."
conflicts=("zfs-utils-git" "zfs-utils-lts")
- cd "${srcdir}/zfs"
+ cd "${srcdir}/zfs-${pkgver}"
make DESTDIR="${pkgdir}" install
# Remove uneeded files