summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIacopo Isimbaldi <isiachi@rhye.it>2016-09-20 21:38:28 +0100
committerIacopo Isimbaldi <isiachi@rhye.it>2016-09-20 21:38:28 +0100
commit2afdc11d69ec6a2099f6447e4a45ef9423c8df19 (patch)
treef7e515cce475a514f4335ad08941eb48c909c2e3
parentUpdated to pkgver 0.6.5.8 (diff)
downloadzfs-dkms-2afdc11d69ec6a2099f6447e4a45ef9423c8df19.tar.xz
Updated to pkgrel 2
Updated hook files (thanks to archzfs)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD2
-rw-r--r--zfs.initcpio.hook97
-rw-r--r--zfs.initcpio.install15
4 files changed, 72 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a37268..daa1d85 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Sep 17 17:04:44 UTC 2016
+# Tue Sep 20 20:37:46 UTC 2016
pkgbase = zfs-dkms
pkgver = 0.6.5.8
- pkgrel = 1
+ pkgrel = 2
url = http://zfsonlinux.org/
arch = i686
arch = x86_64
@@ -21,7 +21,7 @@ pkgbase = zfs-dkms
pkgname = zfs-dkms
pkgdesc = Kernel modules for the Zettabyte File System.
depends = spl-dkms=0.6.5.8
- depends = zfs-utils=0.6.5.8-1
+ depends = zfs-utils=0.6.5.8-2
depends = dkms
provides = zfs
conflicts = zfs-git
diff --git a/PKGBUILD b/PKGBUILD
index 185d498..3037c8c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgbase="zfs-dkms"
pkgname=("zfs-dkms" "zfs-utils")
pkgver=0.6.5.8
-pkgrel=1
+pkgrel=2
license=('CDDL')
makedepends=("git" "spl-dkms=${pkgver}")
arch=("i686" "x86_64")
diff --git a/zfs.initcpio.hook b/zfs.initcpio.hook
index 3a92894..09d081f 100644
--- a/zfs.initcpio.hook
+++ b/zfs.initcpio.hook
@@ -1,8 +1,14 @@
+#
+# WARNING: This script is parsed by ash in busybox at boot time, not bash!
+# http://linux.die.net/man/1/ash
+# https://wiki.ubuntu.com/DashAsBinSh
+# http://www.jpsdomain.org/public/2008-JP_bash_vs_dash.pdf
+#
ZPOOL_FORCE=""
ZPOOL_IMPORT_FLAGS=""
zfs_get_bootfs () {
- for zfs_dataset in $(/usr/bin/zpool list -H -o bootfs); do
+ for zfs_dataset in $(zpool list -H -o bootfs); do
case ${zfs_dataset} in
"" | "-")
# skip this line/dataset
@@ -20,81 +26,94 @@ zfs_get_bootfs () {
}
zfs_mount_handler () {
- local node=$1
- if [ "$ZFS_DATASET" = "bootfs" ] ; then
+ if [ "${ZFS_DATASET}" = "bootfs" ] ; then
if ! zfs_get_bootfs ; then
# Lets import everything and try again
- /usr/bin/zpool import $ZPOOL_IMPORT_FLAGS -N -a $ZPOOL_FORCE
+ zpool import ${ZPOOL_IMPORT_FLAGS} -N -a ${ZPOOL_FORCE}
if ! zfs_get_bootfs ; then
- echo "ZFS: Cannot find bootfs."
- return 1
+ die "ZFS: Cannot find bootfs."
fi
fi
fi
local pool="${ZFS_DATASET%%/*}"
- local rwopt_exp=${rwopt:-ro}
+ local rwopt_exp="${rwopt:-ro}"
- if ! "/usr/bin/zpool" list -H $pool 2>&1 > /dev/null ; then
- if [ "$rwopt_exp" != "rw" ]; then
- msg "ZFS: Importing pool $pool readonly."
- ZPOOL_IMPORT_FLAGS="$ZPOOL_IMPORT_FLAGS -o readonly=on"
+ if ! zpool list -H "${pool}" 2>1 > /dev/null ; then
+ if [ ! "${rwopt_exp}" = "rw" ]; then
+ msg "ZFS: Importing pool ${pool} readonly."
+ ZPOOL_IMPORT_FLAGS="${ZPOOL_IMPORT_FLAGS} -o readonly=on"
else
- msg "ZFS: Importing pool $pool."
+ msg "ZFS: Importing pool ${pool}."
fi
- if ! "/usr/bin/zpool" import $ZPOOL_IMPORT_FLAGS -N $pool $ZPOOL_FORCE ; then
- echo "ZFS: Unable to import pool $pool."
- return 1
+ if ! zpool import ${ZPOOL_IMPORT_FLAGS} -N "${pool}" ${ZPOOL_FORCE} ; then
+ die "ZFS: Unable to import pool ${pool}."
fi
fi
- local mountpoint=$("/usr/bin/zfs" get -H -o value mountpoint $ZFS_DATASET)
- if [ "$mountpoint" = "legacy" ] ; then
- mount -t zfs -o ${rwopt_exp} "$ZFS_DATASET" "$node"
- else
- mount -o zfsutil,${rwopt_exp} -t zfs "$ZFS_DATASET" "$node"
- fi
+ local node="$1"
+ local tab_file="${node}/etc/fstab"
+ local zfs_datasets="$(zfs list -H -o name -t filesystem -r ${ZFS_DATASET})"
+
+ # Mount the root, and any child datasets
+ for dataset in ${zfs_datasets}; do
+ mountpoint=$(zfs get -H -o value mountpoint "${dataset}")
+ case ${mountpoint} in
+ "none")
+ # skip this line/dataset.
+ ;;
+ "legacy")
+ if [ -f "${tab_file}" ]; then
+ if findmnt -snero source -F "${tab_file}" -S "${dataset}" > /dev/null 2>&1; then
+ opt=$(findmnt -snero options -F "${tab_file}" -S "${dataset}")
+ mnt=$(findmnt -snero target -F "${tab_file}" -S "${dataset}")
+ mount -t zfs -o "${opt}" "${dataset}" "${node}${mnt}"
+ fi
+ fi
+ ;;
+ *)
+ mount -t zfs -o "zfsutil,${rwopt_exp}" "${dataset}" "${node}${mountpoint}"
+ ;;
+ esac
+ done
}
run_hook() {
- # Force import the pools, useful if the pool has not properly been exported
- # using 'zpool export <pool>'
- [[ $zfs_force == 1 ]] && ZPOOL_FORCE='-f'
- [[ "$zfs_import_dir" != "" ]] && ZPOOL_IMPORT_FLAGS="$ZPOOL_IMPORT_FLAGS -d $zfs_import_dir"
+ # Force import the pools, useful if the pool has not properly been exported using 'zpool export <pool>'
+ [ ! "${zfs_force}" = "" ] && ZPOOL_FORCE="-f"
- if [ "$root" = 'zfs' ]; then
- mount_handler='zfs_mount_handler'
- fi
+ # Add import directory to import command flags
+ [ ! "${zfs_import_dir}" = "" ] && ZPOOL_IMPORT_FLAGS="${ZPOOL_IMPORT_FLAGS} -d ${zfs_import_dir}"
+
+ # Wait 15 seconds for ZFS devices to show up
+ [ "${zfs_wait}" = "" ] && ZFS_WAIT="15" || ZFS_WAIT="${zfs_wait}"
+
+ [ "${root}" = "zfs" ] && mount_handler="zfs_mount_handler"
- case $zfs in
+ case ${zfs} in
"")
# skip this line/dataset
;;
auto|bootfs)
- ZFS_DATASET='bootfs'
+ ZFS_DATASET="bootfs"
mount_handler="zfs_mount_handler"
;;
*)
- ZFS_DATASET=$zfs
+ ZFS_DATASET="${zfs}"
mount_handler="zfs_mount_handler"
;;
esac
- if [ ! -f "/etc/hostid" ] ; then
- echo "ZFS: No hostid found on kernel command line or /etc/hostid. ZFS pools may not import correctly."
- fi
-
- # Allow up to 10 seconds for zfs device to show up
- for i in 1 2 3 4 5 6 7 8 9 10; do
+ # Allow up to n seconds for zfs device to show up
+ for i in $(seq 1 ${ZFS_WAIT}); do
[ -c "/dev/zfs" ] && break
sleep 1
done
}
-
run_latehook () {
- /usr/bin/zpool import -N -a $ZPOOL_FORCE
+ zpool import -N -a ${ZPOOL_FORCE}
}
# vim:set ts=4 sw=4 ft=sh et:
diff --git a/zfs.initcpio.install b/zfs.initcpio.install
index c128d10..19364a3 100644
--- a/zfs.initcpio.install
+++ b/zfs.initcpio.install
@@ -17,6 +17,7 @@ build() {
dbufstat.py \
fsck.zfs \
mount.zfs \
+ seq \
zdb \
zed \
zfs \
@@ -27,14 +28,15 @@ build() {
zstreamdump \
ztest \
splat \
- hostid \
/lib/udev/vdev_id \
- /lib/udev/zvol_id
+ /lib/udev/zvol_id \
+ findmnt
map add_file \
/lib/udev/rules.d/60-zvol.rules \
/lib/udev/rules.d/69-vdev.rules \
- /lib/udev/rules.d/90-zfs.rules
+ /lib/udev/rules.d/90-zfs.rules \
+ /lib/libgcc_s.so.1
map add_dir \
/etc/zfs/zed.d
@@ -42,11 +44,10 @@ build() {
add_runscript
# allow mount(8) to "autodetect" ZFS
- echo 'zfs' >>"$BUILDROOT/etc/filesystems"
+ echo 'zfs' >>"${BUILDROOT}/etc/filesystems"
[[ -f /etc/zfs/zpool.cache ]] && add_file "/etc/zfs/zpool.cache"
[[ -f /etc/modprobe.d/zfs.conf ]] && add_file "/etc/modprobe.d/zfs.conf"
- [[ -f /etc/hostid ]] && add_file "/etc/hostid"
}
help() {
@@ -73,6 +74,10 @@ Command Line Setup:
If set to 1, this will use "zpool import -f" when attempting to import
pools.
+ To change the seconds of time to wait for ZFS devices to show up at boot:
+
+ zfs_wait=30
+
To search for devices in a directory other than "/dev":
zfs_import_dir=/dev/disk/by-uuid