summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIacopo Isimbaldi <isiachi@rhye.it>2017-02-12 22:33:52 +0000
committerIacopo Isimbaldi <isiachi@rhye.it>2017-02-12 22:33:52 +0000
commit8c86abf3c155bcbf6489d43c9c2a91ae463dc025 (patch)
treee0f3bd4f81a958d5f6038fe8f413f5bd9980e6d3
parentUpdated sha256sums (diff)
downloadzfs-dkms-8c86abf3c155bcbf6489d43c9c2a91ae463dc025.tar.xz
Updated to pkgver 0.6.5.9
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD6
-rw-r--r--zfs.initcpio.hook2
3 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 670793c..6399299 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,27 @@
# Generated by mksrcinfo v8
-# Tue Sep 20 20:43:51 UTC 2016
+# Sun Feb 12 22:33:44 UTC 2017
pkgbase = zfs-dkms
- pkgver = 0.6.5.8
- pkgrel = 2
+ pkgver = 0.6.5.9
+ pkgrel = 1
url = http://zfsonlinux.org/
arch = i686
arch = x86_64
license = CDDL
makedepends = git
- makedepends = spl-dkms=0.6.5.8
- source = git+https://github.com/zfsonlinux/zfs.git#tag=zfs-0.6.5.8
+ makedepends = spl-dkms=0.6.5.9
+ source = git+https://github.com/zfsonlinux/zfs.git#tag=zfs-0.6.5.9
source = zfs.bash-completion-r1
source = zfs.initcpio.install
source = zfs.initcpio.hook
sha256sums = SKIP
sha256sums = b60214f70ffffb62ffe489cbfabd2e069d14ed2a391fac0e36f914238394b540
sha256sums = 17114052aa20c528f022f7f1349971aa28810e2ed2c97871226b5679a91f7e77
- sha256sums = 90d50df503464e8d76770488dbd491cb633ee27984d4d3a31b03f1a4e7492038
+ sha256sums = 138964b43d7a282e1ed5f7fcf1f8dc9baa4f664655b628eeac1912a3017a787b
pkgname = zfs-dkms
pkgdesc = Kernel modules for the Zettabyte File System.
- depends = spl-dkms=0.6.5.8
- depends = zfs-utils=0.6.5.8-2
+ depends = spl-dkms=0.6.5.9
+ depends = zfs-utils=0.6.5.9-1
depends = dkms
provides = zfs
conflicts = zfs-git
diff --git a/PKGBUILD b/PKGBUILD
index 14bfdb4..cab0b4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgbase="zfs-dkms"
pkgname=("zfs-dkms" "zfs-utils")
-pkgver=0.6.5.8
-pkgrel=2
+pkgver=0.6.5.9
+pkgrel=1
license=('CDDL')
makedepends=("git" "spl-dkms=${pkgver}")
arch=("i686" "x86_64")
@@ -17,7 +17,7 @@ source=("git+https://github.com/zfsonlinux/zfs.git#tag=zfs-${pkgver}"
sha256sums=('SKIP'
'b60214f70ffffb62ffe489cbfabd2e069d14ed2a391fac0e36f914238394b540'
'17114052aa20c528f022f7f1349971aa28810e2ed2c97871226b5679a91f7e77'
- '90d50df503464e8d76770488dbd491cb633ee27984d4d3a31b03f1a4e7492038')
+ '138964b43d7a282e1ed5f7fcf1f8dc9baa4f664655b628eeac1912a3017a787b')
build() {
cd "${srcdir}/zfs"
diff --git a/zfs.initcpio.hook b/zfs.initcpio.hook
index 09d081f..222a7e1 100644
--- a/zfs.initcpio.hook
+++ b/zfs.initcpio.hook
@@ -39,7 +39,7 @@ zfs_mount_handler () {
local pool="${ZFS_DATASET%%/*}"
local rwopt_exp="${rwopt:-ro}"
- if ! zpool list -H "${pool}" 2>1 > /dev/null ; then
+ if ! zpool list -H "${pool}" 2&>1 > /dev/null ; then
if [ ! "${rwopt_exp}" = "rw" ]; then
msg "ZFS: Importing pool ${pool} readonly."
ZPOOL_IMPORT_FLAGS="${ZPOOL_IMPORT_FLAGS} -o readonly=on"