summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2021-02-14 15:05:00 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2021-02-14 15:05:00 +0200
commitcbf2f2d573a59e96029d32a9ca2b2c332d61d13b (patch)
treed0cae658028f7c6421d5870feb0349e5d388c9e7
parentUpdate to 2.0.0 (diff)
downloadzfs-dkms-cbf2f2d573a59e96029d32a9ca2b2c332d61d13b.tar.xz
Update to 2.0.2
-rw-r--r--0002-autoconf-2.70-compat.patch67
-rw-r--r--PKGBUILD18
2 files changed, 78 insertions, 7 deletions
diff --git a/0002-autoconf-2.70-compat.patch b/0002-autoconf-2.70-compat.patch
new file mode 100644
index 0000000..9ee98c3
--- /dev/null
+++ b/0002-autoconf-2.70-compat.patch
@@ -0,0 +1,67 @@
+From a1e3ef04e1b2970a40111566b149c86838b1f2b9 Mon Sep 17 00:00:00 2001
+From: Brian Behlendorf <behlendorf1@llnl.gov>
+Date: Mon, 4 Jan 2021 20:12:40 +0000
+Subject: [PATCH] Autoconf 2.70 compat: AM_GNU_GETTEXT
+
+Support for detecting libintl/libiconv, used by gettext(), was added
+in commit e8864b1b. This was an initial step towards being able
+to provide language translations. While the OpenZFS project hasn't
+yet added any translations this did make it possible for end users
+to add their own.
+
+When this support was added using the AM_GNU_GETTEXT_VERSION macro
+was optional. It was therefore omitted and would be revisited if
+OpenZFS ever began providing translations. As of autoconf 2.70 it is
+now mandatory. Unfortunately, simply adding the missing macro call
+isn't desirable since it will result both adding a new dependency on
+the autopoint command, and additional macros and directories for
+full translation support to the repository.
+
+As a compromise to avoid the autoconf 2.70 error this change renames
+the AM_GNU_GETTEXT macro. This effectively let's us avoid the error
+and preserve the current behavior until we either add full support
+for translations or remove gettext() support entirely.
+
+Signed-off-by: Brian Behlendorf <behlendorf1@llnl.gov>
+---
+ config/gettext.m4 | 8 ++++----
+ config/user-gettext.m4 | 2 +-
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/config/gettext.m4 b/config/gettext.m4
+index e7832418ea1..adbf5b3c011 100644
+--- a/config/gettext.m4
++++ b/config/gettext.m4
+@@ -52,17 +52,17 @@ dnl GNU format catalogs when building on a platform with an X/Open gettext),
+ dnl but we keep it in order not to force irrelevant filename changes on the
+ dnl maintainers.
+ dnl
+-AC_DEFUN([AM_GNU_GETTEXT],
++AC_DEFUN([CUSTOM_AM_GNU_GETTEXT],
+ [
+ dnl Argument checking.
+ ifelse([$1], [], , [ifelse([$1], [external], , [ifelse([$1], [use-libtool], ,
+- [errprint([ERROR: invalid first argument to AM_GNU_GETTEXT
++ [errprint([ERROR: invalid first argument to CUSTOM_AM_GNU_GETTEXT
+ ])])])])
+ ifelse(ifelse([$1], [], [old])[]ifelse([$1], [no-libtool], [old]), [old],
+- [errprint([ERROR: Use of AM_GNU_GETTEXT without [external] argument is no longer supported.
++ [errprint([ERROR: Use of CUSTOM_AM_GNU_GETTEXT without [external] argument is no longer supported.
+ ])])
+ ifelse([$2], [], , [ifelse([$2], [need-ngettext], , [ifelse([$2], [need-formatstring-macros], ,
+- [errprint([ERROR: invalid second argument to AM_GNU_GETTEXT
++ [errprint([ERROR: invalid second argument to CUSTOM_AM_GNU_GETTEXT
+ ])])])])
+ define([gt_included_intl],
+ ifelse([$1], [external], [no], [yes]))
+diff --git a/config/user-gettext.m4 b/config/user-gettext.m4
+index 824318eab96..b3ac40c1a96 100644
+--- a/config/user-gettext.m4
++++ b/config/user-gettext.m4
+@@ -2,5 +2,5 @@ dnl #
+ dnl # Check if libintl and possibly libiconv are needed for gettext() functionality
+ dnl #
+ AC_DEFUN([ZFS_AC_CONFIG_USER_GETTEXT], [
+- AM_GNU_GETTEXT([external])
++ CUSTOM_AM_GNU_GETTEXT([external])
+ ])
diff --git a/PKGBUILD b/PKGBUILD
index 4b4f88f..f91646d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Iacopo Isimbaldi <isiachi@rhye.it>
pkgname=zfs-dkms
-pkgver=2.0.0
+pkgver=2.0.2
pkgrel=1
pkgdesc="Kernel modules for the Zettabyte File System."
arch=('any')
@@ -12,13 +12,16 @@ conflicts=('spl-dkms')
provides=("${pkgname%-dkms}" 'spl-dkms')
replaces=('spl-dkms')
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-${pkgver}/zfs-${pkgver}.tar.gz"{,.asc}
- "0001-only-build-the-module-in-dkms.conf.patch")
-sha256sums=('3403bf8e993f3c9d772f768142117df47bdbbb8e9bbf85a29c0e166f577f9311'
+ "0001-only-build-the-module-in-dkms.conf.patch"
+ "0002-autoconf-2.70-compat.patch")
+sha256sums=('bde5067ce4577d26cc0f0313a09173ad40d590d01539b92c93f33f06ee150b24'
'SKIP'
- '780e590383fb00389c5e02ac15709b7a476d9e07d3c4935ed9eb67c951a88409')
-b2sums=('2961b97aa6736af9b4a2bc968d1488f49ec0c0fd7bb22b6bc015047239279efd2d48f8d7c593f9b467ac9d40f99d67363ab551bdfaf1dd71335c37c48c759875'
+ '780e590383fb00389c5e02ac15709b7a476d9e07d3c4935ed9eb67c951a88409'
+ '580bbc43bd1c88c9f64b54d9132fe56ed7bf4d2c21fb9ac1e2281d947334dc47')
+b2sums=('34f4168365d36372349a4986f17cff64987a697e445c2de2ff0bf5d218725fad4aab12b0436ca816300a65856f5918f0cdb8931abeeacd894046daf013bb944f'
'SKIP'
- '1fdae935043d979b9241f07f8baa25a9a0367c24c31c84a59dfe8d6b468a523d8f49b68da3c7fd3194db6638f9d7bef046fc5e2669ce25d73c65009c16bf6c50')
+ '1fdae935043d979b9241f07f8baa25a9a0367c24c31c84a59dfe8d6b468a523d8f49b68da3c7fd3194db6638f9d7bef046fc5e2669ce25d73c65009c16bf6c50'
+ 'fedd8c2e197729e73b8dc7af0aa3db5e449ccdc961ed231eda1cd2675cd201e63dde76e1a7dc5b2ac25fecaa30b4524da75d321af5e5df9dd40df4b7b29abd86')
validpgpkeys=('4F3BA9AB6D1F8D683DC2DFB56AD860EED4598027' # Tony Hutter (GPG key for signing ZFS releases) <hutter2@llnl.gov>
'C33DF142657ED1F7C328A2960AB9E991C6AF658B') # Brian Behlendorf <behlendorf1@llnl.gov>
@@ -26,6 +29,7 @@ prepare() {
cd "${srcdir}"/${pkgname%-dkms}-${pkgver}
patch -p1 -i ../0001-only-build-the-module-in-dkms.conf.patch
+ patch -p1 -i ../0002-autoconf-2.70-compat.patch
# remove unneeded sections from module build
sed -ri "/AC_CONFIG_FILES/,/]\)/{
@@ -51,6 +55,6 @@ package() {
dkmsdir="${pkgdir}/usr/src/${pkgname%-dkms}-${pkgver}"
install -d "${dkmsdir}"/{config,scripts}
cp -a configure dkms.conf Makefile.in META ${pkgname%-dkms}_config.h.in ${pkgname%-dkms}.release.in include/ module/ "${dkmsdir}"/
- cp config/config.* config/missing config/*sh "${dkmsdir}"/config/
+ cp config/compile config/config.* config/missing config/*sh "${dkmsdir}"/config/
cp scripts/enum-extract.pl scripts/dkms.postbuild "${dkmsdir}"/scripts/
}