summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@archlinux.org>2018-11-13 14:11:38 -0500
committerEli Schwartz <eschwartz@archlinux.org>2018-11-13 14:11:38 -0500
commitd6e26984bcfb5deea8aaa4b72b0997c2bf768a7a (patch)
tree62e911badbba10652fc3309322ee8311cbffac65 /PKGBUILD
parentrm unneeded files (diff)
downloadzfs-dkms-d6e26984bcfb5deea8aaa4b72b0997c2bf768a7a.tar.xz
upgpkg: zfs-dkms 0.7.12-1
upstream release Move versioned spl and utils dependencies to package() in order to allow the package to build with mismatched dependencies. In order to install the resulting packages, the dependent packages will need to be installed in the same transaction, but without the build-time dependency, it is no longer necessary to uninstall the package set for as a prerequisite to building the updated packages.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 23e24f3..ff10893 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,12 @@
# Contributor: Iacopo Isimbaldi <isiachi@rhye.it>
pkgname=zfs-dkms
-pkgver=0.7.11
-pkgrel=2
+pkgver=0.7.12
+pkgrel=1
pkgdesc="Kernel modules for the Zettabyte File System."
arch=('any')
url="https://zfsonlinux.org/"
license=('CDDL')
-depends=("spl-dkms=${pkgver}" "zfs-utils=${pkgver}" 'dkms')
makedepends=('git')
provides=("${pkgname%-dkms}")
source=("git+https://github.com/zfsonlinux/zfs.git#tag=zfs-${pkgver}?signed"
@@ -34,6 +33,8 @@ prepare() {
}
package() {
+ depends=("spl-dkms=${pkgver}" "zfs-utils=${pkgver}" 'dkms')
+
cd "${srcdir}"/${pkgname%-dkms}
dkmsdir="${pkgdir}/usr/src/${pkgname%-dkms}-${pkgver}"