summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2022-07-13 10:17:19 +0300
committerAqua-sama <aqua@iserlohn-fortress.net>2022-07-13 10:17:19 +0300
commit3dd8a1f3a88c116e227fb2fffa5450cd2315f4ae (patch)
tree76bc4a1deff4adb3c7e5458ea70eead63f9cbdc2
parentUpdate to 2.1.4 (diff)
parentUpstream 2.1.5 (diff)
downloadzfs-utils-3dd8a1f3a88c116e227fb2fffa5450cd2315f4ae.tar.xz
Merge branch 'master' of https://aur.archlinux.org/zfs-utils
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 99e2cdb..96eb9a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,10 @@
# All my PKGBUILDs are managed at https://github.com/eli-schwartz/pkgbuilds
pkgname=zfs-utils
-pkgver=2.1.4
+pkgver=2.1.5
pkgrel=1
pkgdesc="Userspace utilities for the Zettabyte File System."
-arch=("i686" "x86_64")
+arch=("i686" "x86_64" "aarch64")
url="https://zfsonlinux.org/"
license=('CDDL')
makedepends=('openrc' 'python')
@@ -15,13 +15,22 @@ optdepends=('python: for arcstat/arc_summary/dbufstat')
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-${pkgver}/zfs-${pkgver}.tar.gz"{,.asc}
"zfs.initcpio.install"
"zfs.initcpio.hook")
-b2sums=('be303f1181f604770536aa4aa61d5319ec408abbd04964cedadd15b3101a15deba6539bb5d833f4fed357f323d74f622d035305df699b213df41ae45bffdd200'
+b2sums=('c6e3efd9c0cda91654767eaad0eaaa05cd9a5daf1cb0384c9c78b30062f5c29142ac37ab9dbdaf96c91456d11c317d782d3524ade293f03fda983e5992b79e49'
'SKIP'
'570e995bba07ea0fb424dff191180b8017b6469501964dc0b70fd51e338a4dad260f87cc313489866cbfd1583e4aac2522cf7309c067cc5314eb83c37fe14ff3'
'e14366cbf680e3337d3d478fe759a09be224c963cc5207bee991805312afc49a49e6691f11e5b8bbe8dde60e8d855bd96e7f4f48f24a4c6d4a8c1bab7fc2bba0')
validpgpkeys=('4F3BA9AB6D1F8D683DC2DFB56AD860EED4598027' # Tony Hutter (GPG key for signing ZFS releases) <hutter2@llnl.gov>
'C33DF142657ED1F7C328A2960AB9E991C6AF658B') # Brian Behlendorf <behlendorf1@llnl.gov>
+prepare() {
+ cd "${srcdir}"/zfs-${pkgver}
+
+ # pyzfs is not built, but build system tries to check for python anyway
+ ln -sf /bin/true python3-fake
+
+ autoreconf -fi
+}
+
build() {
cd "${srcdir}"/zfs-${pkgver}