summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonathon Fernyhough <jonathon@m2x.dev>2022-05-25 12:52:37 +0100
committerJonathon Fernyhough <jonathon@m2x.dev>2022-05-25 12:52:37 +0100
commitc8148ca3887ff74614d8c35337a126b559926feb (patch)
tree63ef8cfe0fca986762fe16261c6e179ae1fcecdd /PKGBUILD
parentUpstream 2.1.4 (diff)
downloadzfs-utils-c8148ca3887ff74614d8c35337a126b559926feb.tar.xz
Temporarily use 2.1.5 staging branch for kernel 5.18 compatiblity
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f575eca..b6c2d39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,36 +4,38 @@
# All my PKGBUILDs are managed at https://github.com/eli-schwartz/pkgbuilds
pkgname=zfs-utils
-pkgver=2.1.4
+pkgver=2.1.4+65.r05147319b0
pkgrel=1
pkgdesc="Userspace utilities for the Zettabyte File System."
-arch=("i686" "x86_64")
+arch=("i686" "x86_64" "aarch64")
url="https://zfsonlinux.org/"
license=('CDDL')
+makedepends=('git')
optdepends=('python: for arcstat/arc_summary/dbufstat')
-source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-${pkgver}/zfs-${pkgver}.tar.gz"{,.asc}
+#source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-${pkgver}/zfs-${pkgver}.tar.gz"{,.asc}
+source=("git+https://github.com/openzfs/zfs.git#commit=05147319b0821f61fcff743e20605e191d523906"
"zfs.initcpio.install"
"zfs.initcpio.hook")
-sha256sums=('3b52c0d493f806f638dca87dde809f53861cd318c1ebb0e60daeaa061cf1acf6'
- 'SKIP'
+sha256sums=('SKIP'
'da1cdc045d144d2109ec7b5d97c53a69823759d8ecff410e47c3a66b69e6518d'
'9c20256093997f7cfa9e7eb5d85d4a712d528a6ff19ef35b83ad03fb1ceae3bc')
-b2sums=('be303f1181f604770536aa4aa61d5319ec408abbd04964cedadd15b3101a15deba6539bb5d833f4fed357f323d74f622d035305df699b213df41ae45bffdd200'
- 'SKIP'
+b2sums=('SKIP'
'570e995bba07ea0fb424dff191180b8017b6469501964dc0b70fd51e338a4dad260f87cc313489866cbfd1583e4aac2522cf7309c067cc5314eb83c37fe14ff3'
'e14366cbf680e3337d3d478fe759a09be224c963cc5207bee991805312afc49a49e6691f11e5b8bbe8dde60e8d855bd96e7f4f48f24a4c6d4a8c1bab7fc2bba0')
validpgpkeys=('4F3BA9AB6D1F8D683DC2DFB56AD860EED4598027' # Tony Hutter (GPG key for signing ZFS releases) <hutter2@llnl.gov>
'C33DF142657ED1F7C328A2960AB9E991C6AF658B') # Brian Behlendorf <behlendorf1@llnl.gov>
prepare() {
- cd "${srcdir}"/zfs-${pkgver}
+ cd "${srcdir}"/zfs #-${pkgver}
# pyzfs is not built, but build system tries to check for python anyway
ln -sf /bin/true python3-fake
+
+ autoreconf -fi
}
build() {
- cd "${srcdir}"/zfs-${pkgver}
+ cd "${srcdir}"/zfs #-${pkgver}
./configure --prefix=/usr \
--sysconfdir=/etc \
@@ -49,7 +51,7 @@ build() {
}
package() {
- cd "${srcdir}"/zfs-${pkgver}
+ cd "${srcdir}"/zfs #-${pkgver}
make DESTDIR="${pkgdir}" install
install -D -m644 contrib/bash_completion.d/zfs "${pkgdir}"/usr/share/bash-completion/completions/zfs