summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD23
2 files changed, 10 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
deleted file mode 100644
index d453134..0000000
--- a/.SRCINFO
+++ /dev/null
@@ -1,26 +0,0 @@
-pkgbase = zfs-utils
- pkgdesc = Userspace utilities for the Zettabyte File System.
- pkgver = 2.1.5
- pkgrel = 1
- url = https://zfsonlinux.org/
- arch = i686
- arch = x86_64
- arch = aarch64
- license = CDDL
- optdepends = python: for arcstat/arc_summary/dbufstat
- source = https://github.com/zfsonlinux/zfs/releases/download/zfs-2.1.5/zfs-2.1.5.tar.gz
- source = https://github.com/zfsonlinux/zfs/releases/download/zfs-2.1.5/zfs-2.1.5.tar.gz.asc
- source = zfs.initcpio.install
- source = zfs.initcpio.hook
- validpgpkeys = 4F3BA9AB6D1F8D683DC2DFB56AD860EED4598027
- validpgpkeys = C33DF142657ED1F7C328A2960AB9E991C6AF658B
- sha256sums = 1913041e5c44ff07ca384346ad8145aeedf77e77cd1cea9ec5d533246691e10c
- sha256sums = SKIP
- sha256sums = da1cdc045d144d2109ec7b5d97c53a69823759d8ecff410e47c3a66b69e6518d
- sha256sums = 9c20256093997f7cfa9e7eb5d85d4a712d528a6ff19ef35b83ad03fb1ceae3bc
- b2sums = c6e3efd9c0cda91654767eaad0eaaa05cd9a5daf1cb0384c9c78b30062f5c29142ac37ab9dbdaf96c91456d11c317d782d3524ade293f03fda983e5992b79e49
- b2sums = SKIP
- b2sums = 570e995bba07ea0fb424dff191180b8017b6469501964dc0b70fd51e338a4dad260f87cc313489866cbfd1583e4aac2522cf7309c067cc5314eb83c37fe14ff3
- b2sums = e14366cbf680e3337d3d478fe759a09be224c963cc5207bee991805312afc49a49e6691f11e5b8bbe8dde60e8d855bd96e7f4f48f24a4c6d4a8c1bab7fc2bba0
-
-pkgname = zfs-utils
diff --git a/PKGBUILD b/PKGBUILD
index a11aeae..96eb9a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,14 +10,11 @@ pkgdesc="Userspace utilities for the Zettabyte File System."
arch=("i686" "x86_64" "aarch64")
url="https://zfsonlinux.org/"
license=('CDDL')
+makedepends=('openrc' 'python')
optdepends=('python: for arcstat/arc_summary/dbufstat')
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-${pkgver}/zfs-${pkgver}.tar.gz"{,.asc}
"zfs.initcpio.install"
"zfs.initcpio.hook")
-sha256sums=('1913041e5c44ff07ca384346ad8145aeedf77e77cd1cea9ec5d533246691e10c'
- 'SKIP'
- 'da1cdc045d144d2109ec7b5d97c53a69823759d8ecff410e47c3a66b69e6518d'
- '9c20256093997f7cfa9e7eb5d85d4a712d528a6ff19ef35b83ad03fb1ceae3bc')
b2sums=('c6e3efd9c0cda91654767eaad0eaaa05cd9a5daf1cb0384c9c78b30062f5c29142ac37ab9dbdaf96c91456d11c317d782d3524ade293f03fda983e5992b79e49'
'SKIP'
'570e995bba07ea0fb424dff191180b8017b6469501964dc0b70fd51e338a4dad260f87cc313489866cbfd1583e4aac2522cf7309c067cc5314eb83c37fe14ff3'
@@ -42,10 +39,8 @@ build() {
--sbindir=/usr/bin \
--with-mounthelperdir=/usr/bin \
--with-udevdir=/usr/lib/udev \
- --libexecdir=/usr/lib/zfs \
- --with-python="$PWD/python3-fake" \
+ --libexecdir=/usr/lib \
--enable-pyzfs=no \
- --enable-systemd \
--with-config=user
make
}
@@ -54,17 +49,19 @@ package() {
cd "${srcdir}"/zfs-${pkgver}
make DESTDIR="${pkgdir}" install
- install -D -m644 contrib/bash_completion.d/zfs "${pkgdir}"/usr/share/bash-completion/completions/zfs
# Remove uneeded files
- rm -r "${pkgdir}"/etc/init.d
- rm -r "${pkgdir}"/etc/sudoers.d #???
# We're experimenting with dracut in [extra], so start installing this.
#rm -r "${pkgdir}"/usr/lib/dracut
- rm -r "${pkgdir}"/usr/lib/modules-load.d
- rm -r "${pkgdir}"/usr/share/initramfs-tools
- rm -r "${pkgdir}"/usr/share/zfs
+ rm -rf "${pkgdir}"/usr/lib/modules-load.d
+ rm -rf "${pkgdir}"/usr/share/initramfs-tools
+ rm -rf "${pkgdir}"/usr/share/zfs
+
+ # openrc won't run services with #!/bin/sh
+ sed -i "s+\#\!/bin/sh+\#\!/sbin/openrc-run+" "${pkgdir}"/etc/init.d/*
install -D -m644 "${srcdir}"/zfs.initcpio.hook "${pkgdir}"/usr/lib/initcpio/hooks/zfs
install -D -m644 "${srcdir}"/zfs.initcpio.install "${pkgdir}"/usr/lib/initcpio/install/zfs
+
+ install -D -m644 contrib/bash_completion.d/zfs "${pkgdir}"/usr/share/bash-completion/completions/zfs
}