summaryrefslogtreecommitdiff
path: root/no_stage2_artifacts.patch
diff options
context:
space:
mode:
Diffstat (limited to 'no_stage2_artifacts.patch')
-rw-r--r--no_stage2_artifacts.patch19
1 files changed, 11 insertions, 8 deletions
diff --git a/no_stage2_artifacts.patch b/no_stage2_artifacts.patch
index a89edcc..76c25be 100644
--- a/no_stage2_artifacts.patch
+++ b/no_stage2_artifacts.patch
@@ -1,8 +1,11 @@
+ CMakeLists.txt | 2 --
+ 1 file changed, 2 deletions(-)
+
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index bda57634..52599838 100644
+index f70f79c1..13b3b676 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -254,7 +254,6 @@ else()
+@@ -257,7 +257,6 @@ else()
embedded_lld_wasm
embedded_lld_lib
)
@@ -10,11 +13,11 @@ index bda57634..52599838 100644
endif()
# No patches have been applied to SoftFloat-3e
-@@ -775,7 +774,6 @@ if(MSVC OR MINGW)
- target_link_libraries(zig LINK_PUBLIC version)
- endif()
- install(TARGETS zig DESTINATION bin)
+@@ -6640,7 +6639,6 @@ add_library(zig_cpp STATIC ${ZIG_CPP_SOURCES})
+ set_target_properties(zig_cpp PROPERTIES
+ COMPILE_FLAGS ${EXE_CFLAGS}
+ )
-install(TARGETS zig_cpp DESTINATION "${ZIG_CPP_LIB_DIR}")
- foreach(file ${ZIG_C_HEADER_FILES})
- get_filename_component(file_dir "${C_HEADERS_DEST}/${file}" DIRECTORY)
+ add_library(opt_c_util STATIC ${OPTIMIZED_C_SOURCES})
+ set_target_properties(opt_c_util PROPERTIES