summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2020-11-01 20:01:00 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2020-11-01 20:01:00 +0200
commita97f90531826b33cd5b7a2bc6cbef079b8ebaac2 (patch)
tree48e4883ba85dcbaed694362e2717cc08aa2c0c3c /meson.build
downloadqimv-a97f90531826b33cd5b7a2bc6cbef079b8ebaac2.tar.xz
Initial commit
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build32
1 files changed, 32 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..7c3aac3
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,32 @@
+project('qimv', 'cpp',
+ version : '0.1',
+ default_options : ['warning_level=3', 'cpp_std=c++14'])
+
+summary({
+ 'prefix': get_option('prefix'),
+ 'bindir': get_option('bindir'),
+ 'libdir': get_option('libdir'),
+ 'datadir': get_option('datadir')
+}, section: 'Install locations')
+
+cxx = meson.get_compiler('cpp')
+summary({
+ 'id': cxx.get_id(),
+ 'version': cxx.version(),
+ 'linker': cxx.get_linker_id(),
+}, section: 'Compiler')
+
+mod_qt5 = import('qt5')
+dep_qt5 = dependency('qt5', modules: [ 'Core', 'Widgets' ], include_type: 'system')
+
+moc = mod_qt5.preprocess(
+ moc_headers: [ 'src/mainwindow.h' ],
+ ui_files: [ 'src/mainwindow.ui' ],
+ dependencies: dep_qt5
+)
+
+exe = executable('qimv',
+ sources: [ 'src/main.cpp', 'src/mainwindow.cpp', moc ],
+ dependencies: dep_qt5,
+ install: true)
+