aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 10 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index f0f8194..3cc04f1 100644
--- a/meson.build
+++ b/meson.build
@@ -29,12 +29,19 @@ prog_python = import('python').find_installation('python3')
resources_h = custom_target('resources.h',
output: 'resources.h',
input: 'scripts/rcc',
- command: [prog_python, '@INPUT@', '--namespace=staticdata', '--output=@OUTPUT@', files('test/resources.xrc')],
+ command: [prog_python, '@INPUT@', '--namespace=staticdata', '--output=@OUTPUT@', '-', files('test/resources.xrc')],
)
+
+zstd_dictionary = custom_target('zstd_dictionary',
+ output: 'zstd_dict',
+ input: 'scripts/rcc',
+ command: [ prog_python, '@INPUT@', 'Zstd', '--train=@OUTPUT@', files('test/resources.xrc') ]
+)
+
zstd_resources_h = custom_target('zstd_resources.h',
output: 'zstd_resources.h',
- input: 'scripts/rcc',
- command: [prog_python, '@INPUT@', '--namespace=zstd_data', '--compress=Zstd', '--dict=dictionary', '--output=@OUTPUT@', files('test/resources.xrc')],
+ input: [ 'scripts/rcc', zstd_dictionary ],
+ command: [prog_python, '@INPUT0@', '--namespace=zstd_data', '--output=@OUTPUT@', 'Zstd', '--dict=@INPUT1@', files('test/resources.xrc')],
)
test('libembed',