summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrea Diamantini <adjam7@gmail.com>2013-01-08 16:49:31 +0100
committerAndrea Diamantini <adjam7@gmail.com>2013-01-08 16:49:31 +0100
commit14299bca34712251a215a7d20feecab44426632b (patch)
treec5786687daf755bb488ca9dbaa156ca45eefe8a5 /CMakeLists.txt
parentRestore Tab Windows when Restoring the Session (diff)
downloadrekonq-14299bca34712251a215a7d20feecab44426632b.tar.xz
Revert "Rekonq Migration to Nepomuk2"
This reverts commit 6d2519d373350b5e904fb421d688a665dd42c0c1. This let rekonq compile again. Nepomuk2 will be added back when KDE 4.10 will be released.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dfd167bd..11015c55 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -49,11 +49,11 @@ ADD_DEFINITIONS(-DQT_USE_FAST_CONCATENATION -DQT_USE_FAST_OPERATOR_PLUS)
# ==================================================================================
# optional nepomuk requirements
-FIND_PACKAGE(NepomukCore)
+MACRO_OPTIONAL_FIND_PACKAGE(Nepomuk)
+MACRO_BOOL_TO_01(Nepomuk_FOUND HAVE_NEPOMUK)
+
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/config-nepomuk.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/src/config-nepomuk.h )
-IF(NepomukCore_FOUND)
- ADD_DEFINITIONS(-DHAVE_NEPOMUK)
-ENDIF(NepomukCore_FOUND)
# ==================================================================================
# optional QCA2 & QtOAuth requirements
@@ -138,13 +138,13 @@ IF(REKONQ_CAN_BE_COMPILED)
# Nepomuk
- IF(NepomukCore_FOUND)
+ IF(HAVE_NEPOMUK)
MESSAGE(STATUS " Nepomuk Libraries..................... YES")
MESSAGE(STATUS " Rekonq will be compiled with support for bookmarks nepomuk tagging")
- ELSE(NepomukCore_FOUND)
+ ELSE(HAVE_NEPOMUK)
MESSAGE(STATUS " Nepomuk Libraries..................... NO")
MESSAGE(STATUS " Rekonq will be compiled WITHOUT support for bookmarks tagging")
- ENDIF(NepomukCore_FOUND)
+ ENDIF(HAVE_NEPOMUK)
MESSAGE(STATUS "")