summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Čukić <ivan.cukic@kde.org>2012-10-23 19:40:34 +0200
committerIvan Čukić <ivan.cukic@kde.org>2012-10-23 19:40:34 +0200
commit3011d175e9c116d7448cd1b00db59e6be35c9501 (patch)
tree0226cc2615d6a4b3b28dbccfeb41b8636c842a1b /CMakeLists.txt
parentSVN_SILENT made messages (.desktop file) (diff)
downloadrekonq-3011d175e9c116d7448cd1b00db59e6be35c9501.tar.xz
Rekonq reports the open/close document events to activity manager daemon.
By knowing which window contains which documents and which one is in focus, we can do the following: - collect the statistics about visited pages. Further, this provides a score for each document visited, that depends on the number of times it was open, the time the user spent on that location, and the time passed since the last visit. - availability of a global/workspace applet that allows sharing the current document via e-mail, social networks; bookmarking and rating the link, or connecting it to the current activity. (advantage of this is a unified UI for sharing/rating/linking that works with any application) - jump-lists (not impl. yet in plasma) to list top rated documents on a launcher icon or in the task manager applet - krunner can sort the documents based on the score - more things that I haven't thought of yet There is no need to *use* ativities to have these benefits. Activities just serve as manual data clustering to provide more useful scores compared to the one-activity approach. REVIEW:106912
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 030f0fbd..37311a13 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -56,6 +56,15 @@ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/config-nepomuk.h.cmake ${CMAKE_CURREN
# ==================================================================================
+# optional KActivities requirements
+
+MACRO_OPTIONAL_FIND_PACKAGE(KActivities 6.1.0)
+MACRO_BOOL_TO_01(KActivities_FOUND HAVE_KACTIVITIES)
+
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/config-kactivities.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/src/config-kactivities.h )
+
+
+# ==================================================================================
# optional QCA2 & QtOAuth requirements
MACRO_OPTIONAL_FIND_PACKAGE(QCA2)
@@ -146,6 +155,16 @@ IF(REKONQ_CAN_BE_COMPILED)
MESSAGE(STATUS " Rekonq will be compiled WITHOUT support for bookmarks tagging")
ENDIF(HAVE_NEPOMUK)
+ # KActivities
+
+ IF(HAVE_KACTIVITIES)
+ MESSAGE(STATUS " KActivities Libraries................. YES")
+ MESSAGE(STATUS " Rekonq will be compiled with support for document event reporting")
+ ELSE(HAVE_KACTIVITIES)
+ MESSAGE(STATUS " KActivities Libraries................. NO")
+ MESSAGE(STATUS " Rekonq will be compiled WITHOUT support for document event reporting")
+ ENDIF(HAVE_KACTIVITIES)
+
MESSAGE(STATUS "")
# QCA2