summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid E. Narváez <david.narvaez@computer.org>2013-01-07 12:30:23 -0500
committerDavid E. Narváez <david.narvaez@computer.org>2013-01-07 12:30:23 -0500
commit6d2519d373350b5e904fb421d688a665dd42c0c1 (patch)
tree5f76950325088ee14091ae1baf15a9d9e7d48e7a /CMakeLists.txt
parentMake it compile (diff)
downloadrekonq-6d2519d373350b5e904fb421d688a665dd42c0c1.tar.xz
Rekonq Migration to Nepomuk2
Ran the Nepomuk migration script and added a directory with code that has not yet been ported to Nepomuk2. Also did some CMake changes to be able to drop the config-nepomuk.h.cmake file. REVIEW: 108152
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 11015c55..dfd167bd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -49,11 +49,11 @@ ADD_DEFINITIONS(-DQT_USE_FAST_CONCATENATION -DQT_USE_FAST_OPERATOR_PLUS)
# ==================================================================================
# optional nepomuk requirements
-MACRO_OPTIONAL_FIND_PACKAGE(Nepomuk)
-MACRO_BOOL_TO_01(Nepomuk_FOUND HAVE_NEPOMUK)
-
-configure_file(${CMAKE_CURRENT_SOURCE_DIR}/config-nepomuk.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/src/config-nepomuk.h )
+FIND_PACKAGE(NepomukCore)
+IF(NepomukCore_FOUND)
+ ADD_DEFINITIONS(-DHAVE_NEPOMUK)
+ENDIF(NepomukCore_FOUND)
# ==================================================================================
# optional QCA2 & QtOAuth requirements
@@ -138,13 +138,13 @@ IF(REKONQ_CAN_BE_COMPILED)
# Nepomuk
- IF(HAVE_NEPOMUK)
+ IF(NepomukCore_FOUND)
MESSAGE(STATUS " Nepomuk Libraries..................... YES")
MESSAGE(STATUS " Rekonq will be compiled with support for bookmarks nepomuk tagging")
- ELSE(HAVE_NEPOMUK)
+ ELSE(NepomukCore_FOUND)
MESSAGE(STATUS " Nepomuk Libraries..................... NO")
MESSAGE(STATUS " Rekonq will be compiled WITHOUT support for bookmarks tagging")
- ENDIF(HAVE_NEPOMUK)
+ ENDIF(NepomukCore_FOUND)
MESSAGE(STATUS "")