summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrea Diamantini <adjam7@gmail.com>2012-05-27 12:00:28 +0200
committerAndrea Diamantini <adjam7@gmail.com>2012-05-27 23:34:32 +0200
commita33b32930451d479108fce701267f6c8bdc19319 (patch)
treedd45422752326580e8596e0aac3e047b976faca7 /CMakeLists.txt
parentFancy bookmarking on rekonq :) (diff)
downloadrekonq-a33b32930451d479108fce701267f6c8bdc19319.tar.xz
Let nepomuk dependencies being optional
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 585603d0..4f275e15 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -34,12 +34,20 @@ FIND_PACKAGE(Qt4 4.8.0 COMPONENTS QtCore QtGui QtNetwork QtWebKit REQUIRED)
FIND_PACKAGE(KDE4 4.7.0 REQUIRED)
+
INCLUDE(MacroOptionalFindPackage)
INCLUDE(FindPackageHandleStandardArgs)
INCLUDE(KDE4Defaults)
INCLUDE(MacroLibrary)
ADD_DEFINITIONS(-DQT_USE_FAST_CONCATENATION -DQT_USE_FAST_OPERATOR_PLUS)
+# ==================================================================================
+# optional nepomuk requirements
+
+MACRO_OPTIONAL_FIND_PACKAGE(Nepomuk)
+MACRO_BOOL_TO_01(Nepomuk_FOUND HAVE_NEPOMUK)
+
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/config-nepomuk.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-nepomuk.h )
# ==================================================================================
# Log messages
@@ -86,6 +94,22 @@ ELSE(KDE4_FOUND)
ENDIF(KDE4_FOUND)
+# ----------------------- Optional Deps --------------------------------------
+MESSAGE(STATUS "")
+MESSAGE(STATUS "")
+MESSAGE(STATUS " rekonq ${REKONQ_VERSION} OPTIONAL dependencies")
+MESSAGE(STATUS "")
+
+# Nepomuk
+
+IF(HAVE_NEPOMUK)
+ MESSAGE(STATUS " Nepomuk Libraries..................... YES")
+ MESSAGE(STATUS " Rekonq will be compiled with support for bookmarks nepomuk tagging")
+ELSE(HAVE_NEPOMUK)
+ MESSAGE(STATUS " Nepomuk Libraries..................... NO")
+ MESSAGE(STATUS " Rekonq will be compiled WITHOUT support for bookmarks tagging")
+ENDIF(HAVE_NEPOMUK)
+
##### FINAL RESULTS #####
# create suspance..