summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrea Diamantini <adjam7@gmail.com>2013-03-13 17:50:00 +0100
committerAndrea Diamantini <adjam7@gmail.com>2013-03-13 17:50:00 +0100
commita34f7ad76fe02227cc59143d91dabb891c2e3605 (patch)
tree5ff9ed1816a7df7f0e52604882d1367f23ef5d21 /CMakeLists.txt
parentRestore a small portion of (un)ported code (diff)
downloadrekonq-a34f7ad76fe02227cc59143d91dabb891c2e3605.tar.xz
Support Activities
Open links in new tab only if there is a window in the current activity/on the current desktop This code has been written by Jonathan Verner and reviewed (a bit) by me. Hope everyone will be happy now... BUG: 316322 REVIEWED-BY: adjam
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0ae8bddb..5bfaaf4f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -71,6 +71,14 @@ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/config-qtoauth.h.cmake ${CMAKE_CURREN
# ==================================================================================
+# optional KActivities requirements
+
+MACRO_OPTIONAL_FIND_PACKAGE(KActivities 6.1.0)
+MACRO_BOOL_TO_01(KActivities_FOUND HAVE_KACTIVITIES)
+
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/config-kactivities.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/src/config-kactivities.h )
+
+# ==================================================================================
# Log messages
MESSAGE(STATUS "")
@@ -171,6 +179,15 @@ IF(REKONQ_CAN_BE_COMPILED)
MESSAGE(STATUS " Rekonq will be compiled WITHOUT support for opera sync handler")
ENDIF(HAVE_QCA2 AND HAVE_QTOAUTH)
+ # KActivities
+
+ IF(HAVE_KACTIVITIES)
+ MESSAGE(STATUS " KActivities Libraries................. YES")
+ MESSAGE(STATUS " Rekonq will be compiled with support for activities")
+ ELSE(HAVE_KACTIVITIES)
+ MESSAGE(STATUS " KActivities Libraries................. NO")
+ MESSAGE(STATUS " Rekonq will be compiled WITHOUT support for activities")
+ ENDIF(HAVE_KACTIVITIES)
MESSAGE(STATUS "")
MESSAGE(STATUS "-----------------------------------------------------------------------")