summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoraqua <aqua@iserlohn-fortress.net>2022-09-08 10:27:30 +0300
committeraqua <aqua@iserlohn-fortress.net>2022-09-08 16:33:03 +0300
commitaf1eff03c9e839914aab4109970c4a9f6fac8a99 (patch)
treeae11034560b0e1c270614077ffd8f0f7485c7381 /CMakeLists.txt
parentAdd RekonqWindow tests (diff)
downloadrekonq-af1eff03c9e839914aab4109970c4a9f6fac8a99.tar.xz
RekonqSettings: add resetValue and remove value's defaultValue parameter
- generate default rekonqrc and include it in libsettings - Settings uses :/settings/rekonqrc to provide default values - Add Settings::path() to get the default settings location
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ea9ef655..540ed7e2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -117,7 +117,7 @@ add_executable(rekonq ${rekonq_SRCS} third-party/resources.qrc)
target_include_directories(rekonq PRIVATE src)
target_link_libraries(rekonq
spdlog::spdlog Qt6::Widgets SingleApplication::SingleApplication
- settings pluginloader tabbar urlbar
+ settings pluginloader
)
add_custom_target(rekonq_check_license python scripts/check_license.py ${rekonq_SRCS}
WORKING_DIRECTORY ${PROJECT_SOURCE_DIR})