summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrea Diamantini <adjam7@gmail.com>2013-03-13 17:50:00 +0100
committerAndrea Diamantini <adjam7@gmail.com>2013-03-13 17:50:00 +0100
commita34f7ad76fe02227cc59143d91dabb891c2e3605 (patch)
tree5ff9ed1816a7df7f0e52604882d1367f23ef5d21 /src/CMakeLists.txt
parentRestore a small portion of (un)ported code (diff)
downloadrekonq-a34f7ad76fe02227cc59143d91dabb891c2e3605.tar.xz
Support Activities
Open links in new tab only if there is a window in the current activity/on the current desktop This code has been written by Jonathan Verner and reviewed (a bit) by me. Hope everyone will be happy now... BUG: 316322 REVIEWED-BY: adjam
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 6833f27f..4bb6a1d4 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -252,6 +252,13 @@ IF(NepomukCore_FOUND)
)
ENDIF(NepomukCore_FOUND)
+# KActivities optional target link libraries
+IF(HAVE_KACTIVITIES)
+ TARGET_LINK_LIBRARIES( kdeinit_rekonq
+ ${KACTIVITIES_LIBRARY}
+ )
+ENDIF(HAVE_KACTIVITIES)
+
# Opera sync optional link libraries
IF(HAVE_QCA2 AND HAVE_QTOAUTH)
TARGET_LINK_LIBRARIES( kdeinit_rekonq