summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorLindsay Mathieson <lindsay.mathieson@gmail.com>2012-09-17 19:52:53 +0200
committerAndrea Diamantini <adjam7@gmail.com>2012-09-17 19:56:40 +0200
commitb2b2692bf2a24ef4a588c0f94cffde0dbe3c94ac (patch)
tree43deb1c344798373dd2f62de45c36afbef8245ea /src/CMakeLists.txt
parentSVN_SILENT made messages (.desktop file) (diff)
downloadrekonq-b2b2692bf2a24ef4a588c0f94cffde0dbe3c94ac.tar.xz
Integrated spell checking
- inline spell highlighter. This requires WebKit 2.3 to work. - Addition of a suggested replacement word list to the context menu, for the word right clicked on - A standard modeless spell check dialog that works on the current editable text (or selection). Heavily cribbed from Dawit's work on kdewebkitpart. BUG: 305720 CCMAIL: lindsay.mathieson@gmail.com REVIEW: 106417 REVIEWED-BY: adjam
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index c7945398..6c27376f 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -5,6 +5,9 @@ ADD_SUBDIRECTORY( tests )
### ------- SETTING REKONQ FILES..
+add_definitions(-DQT_STATICPLUGIN)
+QT4_WRAP_CPP(wk_HEADERS_MOC qwebkitplatformplugin.h)
+
SET( rekonq_KDEINIT_SRCS
application.cpp
@@ -111,6 +114,9 @@ SET( rekonq_KDEINIT_SRCS
sync/syncftpsettingswidget.cpp
sync/syncgooglesettingswidget.cpp
sync/syncoperasettingswidget.cpp
+ #----------------------------
+ kspellplugin.cpp
+ ${wk_HEADERS_MOC}
)
# Nepomuk OPTIONAL src files