summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrea Diamantini <adjam7@gmail.com>2012-10-23 16:33:42 +0200
committerAndrea Diamantini <adjam7@gmail.com>2012-12-10 02:48:05 +0100
commitc56af1dd8df101f4c25416f1c714c4345bdb3908 (patch)
treea1d7dcbf6472bb861a977303fb4b4ab896285f39 /src/CMakeLists.txt
parentFix tabs restore when some of them were pinned (diff)
downloadrekonq-c56af1dd8df101f4c25416f1c714c4345bdb3908.tar.xz
Add 1.x compatibility kwebapp script and moved webapp logic to 2.0
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 5ab64859..4cbe4d98 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -253,5 +253,9 @@ ENDIF(HAVE_QCA2 AND HAVE_QTOAUTH)
INSTALL( TARGETS rekonq ${INSTALL_TARGETS_DEFAULT_ARGS} )
INSTALL( TARGETS kdeinit_rekonq ${INSTALL_TARGETS_DEFAULT_ARGS} )
+# kwebapp script install (provided for retro-compatibility...)
+FILE( COPY data/kwebapp DESTINATION ${BIN_INSTALL_DIR}
+ FILE_PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE )
+
INSTALL( FILES rekonq.kcfg DESTINATION ${KCFG_INSTALL_DIR} )
INSTALL( FILES webwindow/rekonqui.rc DESTINATION ${DATA_INSTALL_DIR}/rekonq )