summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorBenjamin Poulain <benjamin.poulain@nokia.com>2010-08-18 03:32:50 +0200
committerBenjamin Poulain <benjamin.poulain@nokia.com>2010-08-18 05:04:39 +0200
commitd9028baf5c8261cbad540893465965730386a1cf (patch)
tree2c8f21d2d2dcdd1b74f21f146cd8c6094cb155fc /src/CMakeLists.txt
parentRemove the method pattern() from AdBlockRule (diff)
downloadrekonq-d9028baf5c8261cbad540893465965730386a1cf.tar.xz
Split AdBlock rule in two classes to move the implementation out of it
In order to make special matching rules, we need specialization of the implementation depending on the type of rule. The previous AdBlockRule was entierly based on regexp. The new one is only a factory to a AdBlockRuleImpl, and delegate everything to this implementation. This will allow faster specialization of the ad block rules in the future.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 46e9240c..8f4ac651 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -53,6 +53,7 @@ SET( rekonq_KDEINIT_SRCS
adblock/adblockmanager.cpp
adblock/adblocknetworkreply.cpp
adblock/adblockrule.cpp
+ adblock/adblockrulefallbackimpl.cpp
#----------------------------------------
urlbar/stackedurlbar.cpp
urlbar/urlbar.cpp