summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorPaul Rohrbach <p.b.r@gmx.net>2013-07-30 21:15:24 +0200
committerAndrea Diamantini <adjam7@gmail.com>2013-07-30 21:17:12 +0200
commitf28c7dc42b6b6924e01b4b97736a89acdaddb244 (patch)
treebdca694cfc4da8e1786553f30c6fec6100daa2ee /src/CMakeLists.txt
parentProperly resolve url before pasteAndGo (diff)
downloadrekonq-f28c7dc42b6b6924e01b4b97736a89acdaddb244.tar.xz
Adding domain-specific hiding support to the adblocker.
The domain-specific rules are stored in a QMultiHash, where the key is the domain and the values are the rules for the specified domain. This causes redundancy, because on rule can be applied to more than one domain, but has a really fast look-up time. The code for the generic hiding has not changed and is just relocated. REVIEW: 111521 REVIEWED-BY: adjam
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index c749a693..6df5a647 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -18,6 +18,7 @@ set(rekonq_KDEINIT_SRCS
urlresolver.cpp
websnap.cpp
#----------------------------------------
+ adblock/adblockelementhiding.cpp
adblock/adblockhostmatcher.cpp
adblock/adblockmanager.cpp
adblock/adblockrule.cpp
@@ -74,7 +75,7 @@ set(rekonq_KDEINIT_SRCS
sync/sshsynchandler.cpp
sync/syncgooglesettingswidget.cpp
sync/syncoperasettingswidget.cpp
- sync/syncsshsettingswidget.cpp
+ sync/syncsshsettingswidget.cpp
#----------------------------------------
tabwindow/rwindow.cpp
tabwindow/rekonqwindow.cpp