summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrea Diamantini <adjam7@gmail.com>2012-07-29 11:22:24 +0200
committerAndrea Diamantini <adjam7@gmail.com>2012-12-10 02:48:04 +0100
commitfe7c06fffa370f8f04a3035f3ae92975ea39b960 (patch)
treef60ad5a2bd0c72ccac0c195dc5630c15071e35f2 /src/CMakeLists.txt
parentClass Application Import, first (important) part (diff)
downloadrekonq-fe7c06fffa370f8f04a3035f3ae92975ea39b960.tar.xz
Insert back HistoryManager
There are a few notable changes here: - rekonq_defines.h clean up, removing the enums from there - let HistoryManager be accessible by a self function
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 6150691e..a15e2c62 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -8,10 +8,14 @@ ADD_SUBDIRECTORY( data )
set(rekonq_KDEINIT_SRCS
#----------------------------------------
application.cpp
+ autosaver.cpp
searchengine.cpp
urlresolver.cpp
websnap.cpp
#----------------------------------------
+ history/historymanager.cpp
+ history/historymodels.cpp
+ #----------------------------------------
tabwindow/tabbar.cpp
tabwindow/tabhighlighteffect.cpp
tabwindow/tabpreviewpopup.cpp
@@ -26,6 +30,7 @@ set(rekonq_KDEINIT_SRCS
### ------------- INCLUDING DIRECTORIES...
INCLUDE_DIRECTORIES ( ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/history
${CMAKE_CURRENT_SOURCE_DIR}/tabwindow
${CMAKE_CURRENT_SOURCE_DIR}/webwindow
${CMAKE_CURRENT_BINARY_DIR}