summaryrefslogtreecommitdiff
path: root/src/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrea Diamantini <adjam7@gmail.com>2009-11-02 22:14:53 +0100
committerAndrea Diamantini <adjam7@gmail.com>2009-11-02 22:14:53 +0100
commit3ab194eb596995a101756fcb92f4294e2dcb3ba1 (patch)
tree5fbff742e0fdb6305c28aad32d6ef0414ea8db2f /src/tests/CMakeLists.txt
parentCompiling rekonq as a kdeinit executable (diff)
downloadrekonq-3ab194eb596995a101756fcb92f4294e2dcb3ba1.tar.xz
Finally... unit tests!!
First test is trivial, but it's a test (tabbar test). And now we have it!
Diffstat (limited to 'src/tests/CMakeLists.txt')
-rw-r--r--src/tests/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/tests/CMakeLists.txt b/src/tests/CMakeLists.txt
new file mode 100644
index 00000000..9963acd4
--- /dev/null
+++ b/src/tests/CMakeLists.txt
@@ -0,0 +1,22 @@
+### ---------- General Settings -------
+
+SET( EXECUTABLE_OUTPUT_PATH ${CMAKE_CURRENT_BINARY_DIR} )
+
+INCLUDE_DIRECTORIES ( ${CMAKE_CURRENT_BINARY_DIR}/..
+ ${KDE4_INCLUDES}
+ ${QT4_INCLUDES}
+)
+
+##### -------------tabbar test
+
+kde4_add_unit_test( tabbar_test TEST tabbar_test.cpp )
+
+target_link_libraries( tabbar_test
+ kdeinit_rekonq
+ ${KDE4_KDECORE_LIBS}
+ ${KDE4_KDEUI_LIBS}
+ ${QT_QTCORE_LIBRARY}
+ ${QT_QTTEST_LIBRARY}
+)
+
+# --------------