summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 6bf47516..1877a108 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -102,6 +102,14 @@ IF(HAVE_QCA2 AND HAVE_QTOAUTH)
)
ENDIF(HAVE_QCA2 AND HAVE_QTOAUTH)
+# tests
+if(${CMAKE_BUILD_TYPE} STREQUAL "Debug")
+ add_executable(test_application test/test_application.cpp test/application_mock.hpp
+ application_instance.cpp application.hpp)
+ target_compile_definitions(test_application PRIVATE REKONQ_TEST)
+ target_link_libraries(test_application GTest::gtest GTest::gmock GTest::gtest_main SingleApplication::SingleApplication)
+ gtest_discover_tests(test_application)
+endif()
### ------------ INSTALL FILES...