aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorItay Grudev <itay+github.com@grudev.com>2022-06-10 00:16:58 +0300
committerGitHub <noreply@github.com>2022-06-10 00:16:58 +0300
commitf1e15081dc57a9c03f7f4f165677f18802e1437a (patch)
tree87d5eecd15798d0833658ef5430dc403bff6cc79 /CMakeLists.txt
parentMerge pull request #160 from itay-grudev/itay-grudev-patch-1 (diff)
parentDisable documentation by default (diff)
downloadsingleapplication-master.tar.xz
Merge pull request #161 from itay-grudev/opt-out-doxygenHEADmaster
Add an option to disable Doxygen
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fba9be0..174d56c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,7 +29,11 @@ else()
endif()
find_package(Qt${QT_DEFAULT_MAJOR_VERSION} COMPONENTS ${QT_COMPONENTS} REQUIRED)
-find_package(Doxygen)
+
+option(SINGLEAPPLICATION_DOCUMENTATION "Generate Doxygen documentation" OFF)
+if(SINGLEAPPLICATION_DOCUMENTATION)
+ find_package(Doxygen)
+endif()
target_link_libraries(${PROJECT_NAME} PUBLIC ${QT_LIBRARIES})