aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHennadii Chernyshchyk <genaloner@gmail.com>2022-04-06 00:04:31 +0300
committerHennadii Chernyshchyk <genaloner@gmail.com>2022-04-06 00:32:30 +0300
commitefdfa507dd5c534dd775bf817d155a34f9a1e6be (patch)
tree72b8224d83e272769d89efb8feb1007399413db6 /CMakeLists.txt
parentUpdate CHANGELOG.md (diff)
downloadsingleapplication-efdfa507dd5c534dd775bf817d155a34f9a1e6be.tar.xz
Switch to Doxygen to avoid documentation duplication
I also had to fix syntax a little in markdown and the header file. Now checked on CI.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 780fbad..98d6cda 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,6 +29,7 @@ else()
endif()
find_package(Qt${QT_DEFAULT_MAJOR_VERSION} COMPONENTS ${QT_COMPONENTS} REQUIRED)
+find_package(Doxygen)
target_link_libraries(${PROJECT_NAME} PUBLIC ${QT_LIBRARIES})
@@ -48,3 +49,14 @@ target_compile_definitions(${PROJECT_NAME} PRIVATE
QT_NO_KEYWORDS
QT_NO_FOREACH
)
+
+if(DOXYGEN_FOUND)
+ set(DOXYGEN_USE_MDFILE_AS_MAINPAGE README.md)
+
+ doxygen_add_docs(${PROJECT_NAME}Documentation
+ singleapplication.h
+ CHANGELOG.md
+ Windows.md
+ README.md
+ )
+endif()