aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fba9be0..174d56c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,7 +29,11 @@ else()
endif()
find_package(Qt${QT_DEFAULT_MAJOR_VERSION} COMPONENTS ${QT_COMPONENTS} REQUIRED)
-find_package(Doxygen)
+
+option(SINGLEAPPLICATION_DOCUMENTATION "Generate Doxygen documentation" OFF)
+if(SINGLEAPPLICATION_DOCUMENTATION)
+ find_package(Doxygen)
+endif()
target_link_libraries(${PROJECT_NAME} PUBLIC ${QT_LIBRARIES})