aboutsummaryrefslogtreecommitdiff
path: root/examples/calculator/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2020-04-13 11:35:02 +0300
committerAqua-sama <aqua@iserlohn-fortress.net>2020-04-13 11:35:02 +0300
commit6f2169ca6924100f309039efb502ae1af2d27113 (patch)
tree82efcb543cea648bf0e9c636947571d7e3ae85f9 /examples/calculator/CMakeLists.txt
parentFix old-style cast warnings (diff)
downloadsingleapplication-6f2169ca6924100f309039efb502ae1af2d27113.tar.xz
Add meson build support
Remove CMakeLists and qmake project files
Diffstat (limited to 'examples/calculator/CMakeLists.txt')
-rw-r--r--examples/calculator/CMakeLists.txt20
1 files changed, 0 insertions, 20 deletions
diff --git a/examples/calculator/CMakeLists.txt b/examples/calculator/CMakeLists.txt
deleted file mode 100644
index c90257a..0000000
--- a/examples/calculator/CMakeLists.txt
+++ /dev/null
@@ -1,20 +0,0 @@
-cmake_minimum_required(VERSION 3.1.0)
-
-project(calculator)
-
-set(CMAKE_AUTOMOC ON)
-
-# SingleApplication base class
-set(QAPPLICATION_CLASS QApplication CACHE STRING "Inheritance class for SingleApplication")
-
-add_executable(${PROJECT_NAME}
- button.h
- calculator.h
- button.cpp
- calculator.cpp
- main.cpp
- )
-
-find_package(Qt5 COMPONENTS Widgets REQUIRED)
-add_subdirectory(../.. SingleApplication)
-target_link_libraries(${PROJECT_NAME} Qt5::Widgets SingleApplication)